1

Had samba working fine on Ubuntu 16.04. Could view a list of shares and was able to access them from any of my various workstations and OS's. Upgraded to 18.04, now when I connect to the Ubuntu server from my Mac, I only see my home folder and none of my other shares. I've only tried viewing on my Mac, so maybe other OS's will see them. Still need to fix this on my Mac though. If I click on "Go" in finder I can type the server name and share I want access to and am able to browse that share so they do exist and are accessible.

Funny thing is, I don't have my home folder configured in my /etc/samba/smb.conf file as I don't use or save anything in my home folder.

I've tried my googlefu, but it's not working for me so not finding anything even close to being relevant to this issue. I don't know where the config for my home folder is coming from and why nothing in my smb.conf file is visible.

How do I restore the functionality I had with Samba prior to upgrading to 18.04? What changed that would cause this between versions?

Added requested info:

name@host:/etc/samba$ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[Data]"
Loaded services file OK.
Server role: ROLE_STANDALONE

# Global parameters
[global]
    dns proxy = No
    log file = /var/log/samba/log.%m
    max log size = 1000
    panic action = /usr/share/samba/panic-action %d
    security = USER
    server string = %h server (Samba, Mythbuntu)
    workgroup = MSHOME
    idmap config * : backend = tdb


[Data]
    comment = Data Share
    create mask = 0644
    path = /share/data
    read only = No
name@host:/etc/samba$


name@host:/etc/samba$net usershare info --long
name@host:/etc/samba$

Nothing is output from that command. Tried with sudo, no difference.

user@host:/etc/samba$ cat smb.conf
[global]
workgroup = MSHOME
server string = %h server (Samba, Mythbuntu)
log file = /var/log/samba/log.%m
max log size = 1000
# syslog = 0
panic action = /usr/share/samba/panic-action %d
dns proxy = no
security = user

[Data]
comment = Data Share
path = /share/data
browseable = yes
public = no
writable = yes
create mask = 0644
directory mask = 0755
user@host:/etc/samba$ 

Update: I rebooted my machine to Windows 10 and was able to access my shares as I normally have, using the same password as before I upgraded the server. Rebooted back to Mac and realized I'm using a different password to access the server. Same username, but different password. I tried the same password as I did in Windows, but it doesn't work on the Mac. Mac is running High Sierra with the latest version of that OS.

A bit of clarity, I'm using a different password for Samba than I use to log in to Ubuntu. The old password that works with Windows is the samba password. This password worked fine on the Mac before the upgrade. Now, the Mac will not accept this password no matter how I format the username. It does accept the password I use on my account. Hoping that sheds some light on what might be going on. Windows 10, btw, does not accept the password on my account, only the samba password.

Update 2: I've deleted the original output from testparm, changed the contents of my smb.file to a real share that has a real path that I'm willing to share. This change made no difference to what my Mac shows me and I can access it directly. I just don't see it when looking at my Ubuntu server after logging in where all shares used to be shown. I still see my home folder which is not in my smb.conf file. Mac is behaving like it is accessing a different config than Windows since my password is different and the list of shares shown is different. Windows does not show my home folder at all, I only see it on my Mac. Another thing I've noticed that I think is new asI haven't noticed this option before upgrading, Mac now shows me a separate item for the server that allows me to easily see my home x session via VNC.

Update 3: Still trying to figure out why Mac doesn't list the network shares like it used to. Thought this was something with Samba. Tried running smbutil on the Mac, it is able to list all available samba shares and the list matches what is in the smb.conf file. Then I stopped the samba service on the Ubuntu server. I can still log in via Finder and Finder still shows and allows me to connect to my "Home Directory". I have not been able to find anything about what is providing this service in Ubuntu, but it's not Samba. The advertising is probably Bonjour, but I've found nothing about how to configure this. This is probably specific to Mac and there's no documentation that I can find about how this is done.

  • Please edit your question and add the output of the following commands: testparm -s and net usershare info --long – Morbius1 Apr 17 at 10:41
  • I don't know what "<..Clip..> - My entire smb.conf file is shown here" is supposed to mean and your share path is too obfuscated. I can't use your output. – Morbius1 Apr 18 at 11:04
  • It means I don't 'want to post everything that's in my smb.conf file. I did provide an example of one of my entries while obfuscating the true path. Path should not be relevent to the issue since the entry is working in Windows. I've isolated the issue to my Mac OS. – MysticGhoster Apr 18 at 20:58
  • I've updated the output above to include the Global section since that may have relevant info in it. I have about a dozen shares, you shouldn't really need to see all of them. None of them have a path to my home directory and Windows does not show one either. Only MacOS is exclusively showing that and I don't know why. If there's something specific you're looking for let me know and I can address that specifically. – MysticGhoster Apr 18 at 21:12
  • The true path is very much relevant. Take the one share you posted. If the path is /media/your-user-name/shared-folder a guest user ( and that is what you specified when you set public = yes ) will never gain access. That share will never work regardless of path of course because your server does not allow guest access at all. You are missing a line in your global section: map to guest = Bad User. Without it samba defaults to map to guest = Never – Morbius1 Apr 18 at 21:39
0

I am not sure for the Mac but for Windows 10 clients, the problem is the lack of support of WSD (WS-Discovery) protocol. There is a bug report about that: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1831441 The good news is that you can already implement a solution by using the following, as explained in the above mentionned document. I implemented on my ubntu 18.04 server and it works like a charm:

[1] Download the file:

wget https://github.com/christgau/wsdd/archive/master.zip

[2] After unzipping it rename the python script:

sudo mv wsdd-master/src/wsdd.py wsdd-master/src/wsdd

[3] Copy it to /usr/bin

sudo cp wsdd-master/src/wsdd /usr/bin

[4] A systemd service file is already provided in the package it just needs to be copied to the correct location:

sudo cp wsdd-master/etc/systemd/wsdd.service /etc/systemd/system

[5] The wsdd.service file has to be edited to remove references to the nobody user:

#User=nobody
#Group=nobody

[6] Then enable the service:

sudo systemctl daemon-reload
sudo systemctl start wsdd
sudo systemctl enable wsdd
| improve this answer | |
  • Thank you for the reply. I'm not having issues discovering the file server itself, only the shares that are on the file server. – MysticGhoster Apr 18 at 1:58
  • @MarcVanhoomissen. If you found that bug report useful you might consider adding an "affects me too" to the bug report. 4 votes alone will not get the ball rolling in having this in the repositories. – Morbius1 Apr 18 at 21:51
  • @Morbius1 You're right. I aaded 'Affects me too'. – Marc Vanhoomissen Apr 19 at 8:22
0

Found the issue. Posting for the benefit of others that may happen on this later. Hope this helps you.

Went searching for what processes were running on the server (sudo systemctl --state=active) and found that Netatalk was running. This was providing the "Home Directory" share. It went away when I shut Netatalk down and I was still able to use the link in Finder to access my Desktop remotely. When I reconnected to the server, my normal list of shares showed up. This must have been running prior to the upgrade, but wasn't working until it was updated to a more recent version. Or it was installed as part of the upgrade, I've no idea either way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.