0

I have 2 computers an AMD based desktop with Ubuntu desktop upgrades since 12.xx to 14.xx to 16.xx and very early on to 18.04 LTS. The network interface cannot be configured and my network connecttion often fails. in 16.04 that was much easier.

A laptop Samsung R540 I5 with Ubuntu desktop i tried to install 18.04 but the network didn't work, so I installed 16.04 LTS.

I have tried several times to address this situation here and questions have been removed, an incomplete description has been posted (that I cannot find anymore) to remove netplan and go back to IPwhatever. but it didn't solve my problem as some commands didn't result in the required changes or edits to config files were not described in a way that i could understand. my request didn't result in a workable solution

I have a setup on my desktop with many applications and with thesaurus and spellchecker files that have grown, and a lot of config data which I do now where they are and that I lack on my laptop because I don't know where they can be found and tranferring the is undocumented.

Moreover it was installed for using LVM, despite me requesting that LVM wasn't used. I dread the consequences of the fact that I need to reinstall this - which will have to happen anyway - with 16.04 LTS and even when I do so I will have to upgrade not before long and move to 18.04LTS and on to 20xx LTS. But I need an answer to the question * how i can go back to the old Network/IP configuration tools such that i can replicate that after the upgrade to 18 and later 20 LTS lets say based on the config files of 16.04 LTS

output as requested :

derek@Avenger:~$ cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto enp3s0
iface enp3s0 inet dhcp

derek@Avenger:~$ cat /etc/netplan/*.yaml cat:

'/etc/netplan/*.yaml': No such file or directory
  • This is a desktop installation, yes? If you show me your current .yaml files, I can take a look. cat /etc/netplan/*.yaml and cat /etc/network/interfaces. Please use copy/paste, not screenshots, and edit that info into your question. Start comments to me with @heynnema or I may miss them. – heynnema Apr 14 at 20:03
  • Status please... – heynnema Apr 15 at 2:18
  • will send req info in a few minutes – Derek Giroulle Apr 15 at 8:23
  • @heynnema I've appended the requested info – Derek Giroulle Apr 15 at 8:47
2

If you wish to return to using NetworkManager, setup your /etc/netplan/*.yaml file like this...

network:
  version: 2
  renderer: NetworkManager

sudo netplan --debug generate

sudo netplan apply

reboot

Update #1:

Your /etc/network/interfaces file should look like this...

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

And then use the NetworkManager GUI to configure your ethernet connection.

| improve this answer | |
  • SO i gedit a file , I can give it anyname.yaml – Derek Giroulle Apr 15 at 9:01
  • @DerekGiroulle As long as there's only one file, name it 01-NetworkManager.yaml. Also see Update #1 in my answer. If my answer is helpful, please remember to accept it by clicking on the checkmark icon that appears just to the left of my answer. Thanks! – heynnema Apr 15 at 14:23
  • Can you clarify or point me to installation instructions of the NMgiu? – Derek Giroulle Apr 15 at 20:45
  • @DerekGiroulle Nothing to install. It's already there. Just pull down the upper-right menu in the top panel, and look for something like Ethernet Disconnected and if there's a Wired Connection profile, just select it. If you don't see Wired Connection, you'll have to add it. – heynnema Apr 15 at 20:48
  • there are no settings to be modified - this is the blackbox network that I so much resent and that shows =?= status on the upper right menu i cannot modify anything if I want a fixed IP address or DHCP generated address, what my DNS servers are , no settings at all to be changed . That is why I reinstalled 16.04 on my laptop i may be left with days on end without a decent network connection – Derek Giroulle Apr 23 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.