3

I have Ubuntu 18.04 installed on a Hyper-V VM. When I installed Google Chrome, suddenly my keyboard stopped working everywhere except login prompts. I didn't figure out it was Chrome causing the problem until I stopped it running in the background which is when my keyboard started working again. So as soon as I load up Chrome, my keyboard stops working in all programs, terminal etc. As soon as I close Chrome my keyboard starts working again.

Any help with this matter would be appreciated.

4 Answers 4

2

I solved the issue somehow. I reset chrome to its default settings which fixed the issue. I couldn't figure out the exact problem. I'll edit the question if the issue crops up again.

Edit: This is happening repeatedly when I sync my chrome settings. I have to reset chrome to default settings and keep it that way to stop it from disabling my keyboard. Still haven't found the exact culprit.

2
  • I think it was happening due to some extensions or apps. I disabled them all and re-enabled what I needed. That seems to have taken care of the issue.
    – jaibatrik
    Jul 10, 2020 at 11:45
  • In my case, it works fine until at some point, keyboard stop working in chromium only. Still works elsewhere in the OS. I have to kill the parent chromium process to restart chromium and make it work. Do you have the same symptoms? I'm not using any external keyboard neither. I tried to start chromium in a console to have a look at enventual crash logs, without success. :( I'll try to deactivate all extensions and reactivate those one by one. Oct 6, 2020 at 10:27
1

Very strange behaviour. For me, I was trying to open a spreadsheet that has come from previous version of Ubuntu (18.04) - it doesn't appear to recognise the filetype. If I try File->Open from within Calc a valid file is an 'OpenDocument Spreadsheet' but I was seeing a filetype of simply 'File'.

So, 2 ways that didn't work & 1 that did, all trying to open the same file without any changes.

These 2 ways of trying to open a spreadsheet don't work for me:-

  1. Open Calc.

  2. Open MySpreadsheet.ods - keyboard not working

  3. From Files right click on MySpreadsheet.ods and 'Open With LibreOffice Calc' doesn't work either

but this sequence does work:-

  1. Open Calc with new, blank spreadsheet - keyboard works fine.
  2. Open a new instance of Calc by Shift-click on the Calc App again.
  3. Then do File->Open and it is now recognised as an 'OpenDocument Spreadsheet'and the MySpreadsheet.ods opens and works.

Although I don't understand exactly what's going on, it is to do with the file extension being missing sometimes when LibreOffice opens files. Renaming files in file manager with the correct file extension (e.g. .odt .ods) seems to fix them? (I hope!)

p.s. just notice files in question were also marked as 'executable' for some reason, which doesn't sound right - so I unticked that permission.

Update, 3 months later (4th Oct 2020)

Turns out I only had problems with 2 files which I'd carried over from previous versions of Ubuntu, both of which sometimes caused the keyboard to freeze. One was a Libreoffice Calc file and one was a Libreoffice Writer file, both of which had password protection turned on. All other files without password protection worked fine. Pretty sure now my problem was to do with password protection on Libreoffice files.

Simply turning off the password protection for these 2 files works fine, but they were password protected for a reason, so would like a fix.

1

I had the same problem. I don't know what is going on but the problem is solved after I run this command in the terminal:

ibus exit
0

Tapping the Super key twice quickly solved the issue for me. This is the same workaround that is used in Windows for a similar problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.