1

I just installed Ubuntu 19.10 on my Xiaomi Mi Notebook Pro laptop and when I'm plugging my headset, it detects only headphones, but not the mic. This is what i see in settings.

I tried pavucontrol with the same result. Only laptop mic is detected.

Also I checked this headset with another laptop (Lenovo 520-IKB) which had Ubuntu 18.04 on board and it works as expected.

After a couple days of searching the internets i found similar questions, the closest one being this one. I tried setting options snd-hda-intel model=headset-mic and options snd-hda-intel model=headset-mode but that didn't fix the issue for me.

Not sure what to do next. Does anyone have ideas what else can i try?

2

TL;DR: I added

options snd-hda-intel model=alc298-dell1

to /etc/modprobe.d/alsa-base.conf and it worked.

After i posted the question i decided to check out what models can i test in /etc/modprobe.d/alsa-base.conf. I found this information in kernel sources in the ./Documentation/sound/hd-audio/models.rst.

I was trying models that had "headset" in their names. To be more precise first two were headset-mic and headset-mode which i have already tried before i posted the question. So i tried the next one which is dell-headset-multi and it partially fixed my problem. I was able to choose a headset mode when i plugged in my headset. But headset's mic still didn't work.

Then i decided to try specific alc298 models and added to /etc/modprobe.d/alsa-base.conf a line with

options snd-hda-intel model=alc298-dell1

and after that my mic started working.

| improve this answer | |
1

Today 2020.04.29 I have lost my microphone) It suddenly stops working (with and without headset connected). I guess it happend after OS software updates. Switching to the previous Linux headers version was unhelpful

Adding the line

options snd-hda-intel model=alc298-dell1

to the end of file /etc/modprobe.d/alsa-base.conf solved my problems with Xiaomi Notebook Lite 2019 (light) and the following OS:

Operating System: KDE neon 5.18
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2
Kernel Version: 5.3.0-51-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15,5 ГиБ

This notebook has ALC256 sound card

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.