1

I have a FiiO BTR3 and there's something really weird going on when I try to use the USB DAC mode. It allows me to play audio from Firefox, so music playing from the web browser works. However, when I try to play any audio from the Spotify app (snap spotify) or even Google Music Player (snap google-play-music-desktop-player), it won't play any audio - except that BTR3 LED lights up in the USB DAC active mode (white LED, instead of the blue LED which means it's on standby). If I go into audio settings, and change the modes around (analog/digital/built-in), the situation does not change.

However, if I go into Test and check channels while the music is paused, I can hear "left" or "right" depending on which channel I test. If I resume playing music instantly after hearing the channel test, music will begin playing from the Spotify app.

I also looked up some other questions and their answers and tried to change the /etc/pulse/daemon.conf file to set the default-sample-rate to 48000, as suggested but it didn't solve the issue.

Would anyone with experience or knowledge about this help me out, please? I'm really frustrated doing this over and over only to be able to listen to some high quality music. I apologise in advance if I've missed out on something absolutely basic, I'm not very experienced.

2

I had the same trouble - and so happy that fixed it, that wanna share with you. So, your roadmap:

  1. Install pulseaudio

    sudo apt update

    sudo apt install pulseaudio

  2. You should change two rows in config according to this instruction https://github.com/ReimuNotMoe/FiiO-BTR3-USB-Linux-Workaround

    sudo vim /etc/pulse/daemon.conf

default-sample-rate = 192000

alternate-sample-rate = 48000

PS. without ";"

  1. Restart pulseaudio service:

    pulseaudio -k

    pulseaudio --start

  2. Don`t forget to change the sound quality in Spotify settings from high to very hight (if u have prem)

Good luck!

2
  • it's better to override the daemon.conf in your user directory: ~/.pulse/daemon.conf and if it doesn't exist just make a copy of the original – WiR3D Feb 22 at 12:41
  • also unless you have high-resolution it actually introduces more noise to "upscale" audio especially when not doing so in solid multiples (e.g. 48000 -> 96000 is a solid multiple). set default-sample-rate = 48000 and alternate-sample-rate = 96000 – WiR3D Feb 22 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.