0

I've been unsuccessful getting the WUSB6300 to work on Ubuntu 19.10. I've executed the instructions at this website

My output from lsusb is "Bus 002 Device 009: ID 13b1:003f Linksys WUSB6300 802.11a/b/g/n/ac Wireless Adapter [Realtek RTL8812AU]"

My output from lsmod shows the 8812au listed. My output from lshw -C network doesn't show the WSUSB6300, 8812au, or any type of wireless adapter, only the Realtek PCI Express Gigabit Ethernet Controller that's integral to the motherboard.

What am I missing? I can't help thinking that there's something I'm not doing that would enable this dongle to be recognized and used.

Thanks in advance!

EDIT #1
modinfo 8812au |grep 003F

usb:v13B1p003Fd*dc*dsc*dp*ic*isc*ip*in*

dmesg | grep -i rtl

[ 1.504926] r8169 0000:07:00.0 eth0: RTL8168evl/8111evl, 50:e5:49:b8:a6:98, XID 2c9, IRQ 34 [ 6.978205] RTL871X: module init start
[ 6.978206] RTL871X: rtl8812au v4.3.8_12175.20140902
[ 6.978206] RTL871X: build time: Apr 13 2020 13:46:32
[ 7.094661] usbcore: registered new interface driver rtl8812au
[ 7.094662] RTL871X: module init ret=0
[ 7.190684] RTL871X: module init start
[ 7.190685] RTL871X: rtl8812au v4.3.14_13455.20150212_BTCOEX20150128-51
[ 7.190685] RTL871X: rtl8812au BT-Coex version = BTCOEX20150128-51
[ 7.190693] Error: Driver 'rtl8812au' is already registered, aborting...
[ 7.190697] RTL871X: module init ret=-16
[ 17.308006] RTL8211E Gigabit Ethernet r8169-700:00: attached PHY driver
[RTL8211E Gigabit Ethernet] (mii_bus:phy_addr=r8169-700:00, irq=IGNORE)

EDIT #2
sudo updatedb && locate 8812au.ko

/usr/bin/find: '/run/user/1000/doc': Permission denied
/usr/bin/find: '/run/user/1000/gvfs': Permission denied
/usr/lib/modules/5.3.0-46-generic/updates/dkms/8812au.ko
/usr/lib/modules/5.3.0-46-generic/updates/dkms/rtl8812au.ko
/var/lib/dkms/rtl8812AU_8821AU_linux/1.0/5.3.0-46-generic/x86_64/module/rtl8812au.ko
/var/lib/dkms/rtl8812au/4.3.8.12175.20140902+dfsg/5.3.0-46-generic/x86_64/module/8812au.ko

sudo dkms status

rtl8812au, 4.3.8.12175.20140902+dfsg, 5.3.0-46-generic, x86_64: installed rtl8812AU_8821AU_linux, 1.0, 5.3.0-46-generic, x86_64: installed

EDIT #3
sudo modprobe -r 8812au && sudo modprobe rtl8812au
lsmod

Module Size Used by
rtl8812au 1347584 0

Disconnected wired connection, removed/reinserted usb dongle, no change to network behavior, i.e. no wireless connection to local wireless router.

EDIT #4
sudo modprobe -r rtl8812au && sudo modprobe 88au
lsmod

Module Size Used by
8812au 1290240 0
cfg80211 712704 1 8812au

iwconfig

lo no wireless extensions.
enp7s0 no wireless extensions.

sudo dkms status

rtl8812au, 4.3.8.12175.20140902+dfsg, 5.3.0-46-generic, x86_64: installed rtl8812AU_8821AU_linux, 1.0, 5.3.0-46-generic, x86_64: installed

Apologies, I should clarify..this "radio button" is selectable for enable & disable. I've done both, with no difference in connection, i.e. no wireless established after either enabling or disabling

8
  • Please edit your question to add the result of the terminal commands: modinfo 8812au | grep 003F and also: dmesg | grep -i rtl Welcome to Ask Ubuntu. – chili555 Apr 14 '20 at 0:16
  • Please add: sudo updatedb && locate 8812au.ko and also: sudo dkms status You may have two different drivers loading and conflicting. – chili555 Apr 14 '20 at 0:57
  • @chili555 - Is the problem actually that I have two drivers conflicting? If so, what would be the steps to remove the rtl8812au vs the rtl8812AU? – Dartheric Apr 14 '20 at 3:52
  • We don't yet know if that is the actual problem. Let's unload one of the two and see if it helps: sudo modprobe -r 8812au && sudo modprobe rtl8812au Is Secure Boot disabled in the BIOS/EFI? – chili555 Apr 14 '20 at 12:58
  • 1
    "Anyway, that radio button was disabled for the entire set of operations & commands we've been working through." That is probably why the wireless doesn't work! Please press it and try again. The action we are looking for is for the Network Manager icon offer to connect to networks it sees. – chili555 Apr 15 '20 at 0:49
0

I had the same problem with 18.04 and Linksys WUSB6300.

These are the steps I used to get up and persist reboots:

On Ubuntu Server

Install the tools:

sudo apt install wireless-tools && sudo apt install wpasupplicant

Install the driver:

sudo apt install rtl8812au-dkms

Now open.yamlfile in netplan for editing:

sudo vi /etc/netplan/50-cloud-init.yaml

Replace wlan0 with the name of your adapter (do ifconfig to find it).

Netplan file should look similar to this:

network:
version: 2
renderer: networkd
    ethernets:
        eno1:
            addresses: []
            dhcp4: true
            optional: true
    wifis:
        wlan0:
            addresses: []
            dhcp4: true
            dhcp6: true
            access-points:
                "my_essid":
                    password: "my_password"

Now generate and debug:

sudo netplan --debug generate

Apply the configuration:

sudo netplan apply

Now remove ethernet wire and reboot:

sudo reboot

Info:
My sudo dkms status output:

rtl8812au, 4.3.8.12175.20140902+dfsg, 4.15.0-96-generic, x86_64: installed  

And your output has 2 versions of drivers installed. You must uninstall rtl8812AU_8821AU.

Note: Connection and ip established after netplan generate. Omitting optional: true for ethernets will prevent persistence upon reboots.

For Ubuntu Desktop 18.04 through 20.04:

Update the package database:

sudo apt update

Install required packages:

sudo apt install git build-essential

Download the driver:

sudo git clone https://github.com/gnab/rtl8812au

Go to the directory:

cd rtl8812au

Do the next commands consecutively:

sudo make clean
sudo make  
sudo make uninstall 
sudo make install

Reboot and insert USB wireless stick

  • Persists reboots
  • Works for WUSB6300
11
  • Please note - I originally was unable to locate a wlan interface via the lshw -C network command. The only output was the integrated PCI gigabit ethernet interface, not the WSUB6300 or any other wireless interface. – Dartheric Apr 14 '20 at 3:54
  • where would I locate Netplan to compare to the example provided? How do I uninstall the conflicting driver you? what's the actual order of steps, uninstall first or install rtl8812au-dkms and then uninstall? – Dartheric Apr 14 '20 at 4:01
  • install wireless-tools as suggested above and edit your question to show output of iwconfig. Netplan is located in /etc, to see the default neplan file you have to do cd /etc/netplan then command ls and look for a file ending in .yaml; this would be your network configuration file. As per the rtl8812AU_8821AU driver, yes you would need to uninstall this first and chili555 would definitely know how to do this. – kkyucon Apr 14 '20 at 6:02
  • I tried searching for a way to uninstall the rtl8812AU_8821AU driver that I installed previously using the instructions from this website (askubuntu.com/questions/642794/…), but I'm not finding anything. Is that a question I should post separate from this thread? – Dartheric Apr 14 '20 at 12:21
  • @kkyucon Please explain why you recommend netplan, generally apprpriate for servers, instead of Network Manager. Why do you evidently suspect that Network Manager is the issue? Why do you recommend installing a third version of the driver? Aren't nettools and wpa-supplicant already installed in a desktop environment in Ubuntu? – chili555 Apr 14 '20 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.