4

I have a Dell G3 15. Running Xubuntu 18.04. Everything was working perfectly until the 26/27th February 2020. After this the audio stopped working and I only see a dummy output in the mixer. Im guessing there was an update at this time. I think the Laptop has a ALC3204 sound card. I found that if I plug in a hdmi display I can play audio through the hdmi.

Things I have tried:

  • Reinstalled Pulse Audio and rebooted.
  • Disabled Secure Boot.
  • Opened the terminal and ran sudo apt-get install pavucontrol pavucontrol then entered configuration profile to set configuration to analog stereo out, only to find "dummy output" as the only option again.
  • Opened the terminal and ran sudo alsa force-reload.
  • pulseaudio -k && sudo alsa force-reload had no effect.
  • BIOS -> disable audio -> boot to Ubuntu -> restart -> BIOS -> enable audio -> boot to Ubuntu did not work. I still have "Dummy output" as the only sound output option.
  • I went onto the dell site to see if I could download a new driver for the Realtek ALC3204 but the only drivers that I could find on the site are only for Windows 10.
  • added "options snd-hda-intel model=headset-mic probe_mask=0x103" to /etc/modprobe.d/alsa-base.conf , btw this stops the hdmi audio working after a restart. So if i do this I have no audio no matter what I do.
  • I tried a USB audio "card" it works fine.
  • I just added, snd_hda_intel.dmic_detect=0 to this line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash mem_sleep_default=deep" in /etc/default/grub then ran update-grub and restarted. the headphone jack now works, speaker and mic still don't work.

Some outputs

G3-3590:~$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
G3-3590:~$ sudo inxi -Fxz
System:    Host: plakkies-G3-3590 Kernel: 5.3.0-46-generic x86_64
           bits: 64 gcc: 7.5.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Ubuntu 18.04.4 LTS
Machine:   Device: laptop System: Dell product: G3 3590 serial: <filter>
           Mobo: Dell model: 061RYD v: A00 serial: <filter>
           UEFI: Dell v: 1.6.0 date: 08/08/2019
Battery    BAT0: charge: 46.1 Wh 100.0% condition: 46.1/51.0 Wh (90%)
           model: LGC-LGC4.474 DELL 415CG98 status: Full
CPU:       6 core Intel Core i7-9750H (-MT-MCP-) 
           arch: Skylake rev.10 cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 31199
           clock speeds: max: 4500 MHz 1: 1370 MHz 2: 3619 MHz 3: 4391 MHz
           4: 3604 MHz 5: 3808 MHz 6: 3193 MHz 7: 4152 MHz 8: 3590 MHz
           9: 3847 MHz 10: 3612 MHz 11: 3615 MHz 12: 3585 MHz
Graphics:  Card-1: Intel Device 3e9b bus-ID: 00:02.0
           Card-2: NVIDIA Device 2191 bus-ID: 01:00.0
           Display Server: X.Org 1.20.5
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2
           version: 4.6.0 NVIDIA 435.21 Direct Render: Yes
Audio:     Card-1 Intel Cannon Lake PCH cAVS
           driver: sof-audio-pci bus-ID: 00:1f.3
           Card-2 NVIDIA Device 1aeb driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k5.3.0-46-generic
G3-3590:~$ dmesg |grep audio
[    3.555373] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.640969] sof-audio-pci 0000:00:1f.3: warning: No matching ASoC machine driver found
[    3.640974] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
[    3.641097] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[    3.645485] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.649680] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[    3.649682] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    3.701574] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2
[    3.701577] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cfl.ri failed err: -2
[    3.701580] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[    3.701945] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2
[    3.925713] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
[    3.925716] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.925717] snd_hda_codec_generic hdaudioC0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.925717] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[    3.925718] snd_hda_codec_generic hdaudioC0D0:    dig-out=0x7/0x0
[    3.925718] snd_hda_codec_generic hdaudioC0D0:    inputs:
[    4.755902] usbcore: registered new interface driver snd-usb-audio

Thanks for any help you can provide.

3

An additional kernel parameter may help see Audio broken.

Open /etc/default/grub as root and add 'snd_hda_intel.dmic_detect=0' to this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"

after that execute

grub-mkconfig -o /boot/grub/grub.cfg

in terminal and reboot.

1
  • 1
    Works like a charm. I needed to run alsactl restore before it worked though after rebooting Jun 16 '20 at 20:57
0

found the answer with some help. I asked someone who knows more than me and was pointed to this. How do I get sound with an HDA card?

It solved the issue.

Just in case that link disappears here are the steps followed.

open alsa-base.conf as root - e.g.:

sudo gedit /etc/modprobe.d/alsa-base.conf

and add the following lines at the end of the file

options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1
options snd-hda-intel model=basic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.