I am trying to create a live Ubuntu 18.04 USB drive (16 GB) with persistent storage (1 GB) using Rufus 3.9.1624. I ran Rufus with the following settings. However, upon booting up the USB drive, I get the following screen, showing BusyBox and a initramfs prompt. I even tried using a different USB but got the same problem. But if I disable persistent storage, then it works (I also tried using a lower amount of persistent storage i.e. 100 MB). Is there anything else that needs to be configured to get it to work with persistent storage?

  • Welcome to Ask Ubuntu. Is your casper-rw partition full? That will keep a persistent drive from booting. 100MB is too small. Apr 12 '20 at 3:15
  • @C.S.Cameron, 18.04 + persistence + mounting /cow on /root failed = bugs.launchpad.net/bugs/1489855, so make sure you try to remember that one, because until 20.04 is released (which brought its own share of issues), we're going to continue seeing people reporting that one over and over again...
    – Akeo
    Apr 12 '20 at 11:21
  • @Akeo: As I recall this was the problem that started back about 14.04 concerning Syslinux booters with casper-rw partitions on the same drive. This problem did not apply to Grub booters with casper-rw partitions such as mkusb and hand made Grub ISO multibooters. I had almost forgotten that Rufus did not include Persistence until recently. I have not tried Rufus with Persistent 18.04 until today. Apr 13 '20 at 5:06
  • "concerning Syslinux booters" That is not correct. If you had read the bug you would see that it has nothing to do with Syslinux (it will manifest itself if you simply create 2 partitions and copy the whole content of the ISO to the first one, and then boot in UEFI mode with the default GRUB UEFI bootloader from the ISO). So "Grub booters" do fail. Also, your assertion that Rufus is a "Syslinux" booter is wrong (at least for UEFI, but in terms of BIOS we simply use what the ISO use, and if Ubuntu used GRUB for BIOS, Rufus would use GRUB too, like it does for other images).
    – Akeo
    Apr 13 '20 at 11:02
  • @Akeo: Making a Grub2 booter that uses Persistent partitions is not a problem, if you do it the right way. Start with a 1MB grub2 core.img partition flagged bios_grub. Add a 250MB FAT32 EFI partition flagged boot,esp. next add an ext4 partition large enough for the Ubuntu ISO's contents and finish with a ext4 casper-rw partition and a NTFS data partition if desired. Copy the ISO's contents to the root partition and recopy boot and EFI folders to to the EFI partition. Mount the EFI partition to mnt and Install grub. Add set root=(hd0,3) to grub.cfg. I think Grub2 does not like a FAT32 root. Apr 15 '20 at 4:58

If you perform a quick search, you will find numerous posts with the error:

mount: mounting /cow on /root failed: Invalid argument
overlay mount failed

This is due to the fact that Ubuntu 18.04 has a MAJOR BUG that prevents it from mounting a persistent partition residing on the same drive, and this bug was only fixed in Ubuntu 19.10. So you must either:

  • Use Ubuntu 19.10 if you want to add peristence in Rufus, or
  • Disable persistence altogether

Next time, please try to perform a search for the error message you get, as you should have found existing questions with the answer you seek.


Persistent Partitions 18.04

From 14.04 to 18.04 persistent partitions did not work with Syslinux bootable USB's unless the casper-rw partition was on a seperate drive.

Mkusb, https://help.ubuntu.com/community/mkusb, uses Grub2 for booting and Persistent partitions do work.

It is possible to download and install mkusb to your Live Rufus drive and use it to install Persistent Ubuntu on a second USB. It is also possible to install Persistent Ubuntu to the Live Rufus drive it was booted from. Can a Persistent Ubuntu install be made to the pendrive it was booted from?

Change Live USB to Persistent USB

It is also possible to change a Rufus Live USB to a Persistent USB using a casper-rw file: Can I convert a live Ubuntu USB to one with persistent memory? Size is limited to 4GB (or 8GB adding a home-rw file).

  • 1
    "did not work with Syslinux bootable USB's unless the casper-rw partition was on a seperate drive" That is not correct, it affects EFI GRUB as well. Also "Rufus uses Syslinux to make it's bootable USB's" is wrong. There are a few too many innacuracies in the above, so please try to correct them.
    – Akeo
    Apr 13 '20 at 10:55
  • @Akeo: If my statement is not correct, please show us a Syslinux installer that does work with Persistent partitions. My experience shows that same disk Persistent partitions work on Grub2 Installs made using mkusb and made by hand. It also shows that Persistent partitions do not work on Syslinux installs of Ubuntu 14.04 through 18.04. A Rufus 3.9 Ubuntu install shows a Syslinux header when booting from BIOS mode It also show a GRUB header when trying to boot in UEFI mode, like every other installer that works in UEFI. Apr 14 '20 at 4:21
  • "My experience shows that same disk Persistent partitions work on Grub2 Installs made using mkusb and made by hand." Then please read the bug, as it indicates how a GRUB 2 UEFI media, created by hand, does fail. You just need to create 2 partitions, extract the whole ISO content on the first one (FAT32) and have the persistent partition on the second, and you're get the mounting /cow on /root failed error. What I describe is a common way of creating persistent media, that doesn't require Rufus or mkusb and that completely fails with 18.04.
    – Akeo
    Apr 14 '20 at 11:28
  • The problem I have is that you seem to present Rufus as a Syslinux installer (which is incorrect) and as the problematic entity (which is incorrect), on account that the mkusb folks appear to somehow have noticed that there was an issue, and added a major work around for it in their app (since, it appears to work in GRUB/UEFI mode whereas it shouldn't), rather than work with the Ubuntu developers to get this fixed, which is precisely what we did. In other words, it feels like you are misrepresenting the issue to make it look like a Rufus specific problem which is woefully incorrect.
    – Akeo
    Apr 14 '20 at 11:34
  • The thing is, Rufus does not add Syslinux or GRUB, it just follows that the ISO uses, and reuses the bootloaders that the ISO maintainers went for. So when Ubuntu decides to go with Syslinux for BIOS and GRUB for UEFI, Rufus follows suit. So, and this is the part that has a MAJOR ISSUE in your reasoning, mkusb working because it "uses" GRUB2, and Rufus failing because it "uses" Syslinux, is incorrect, because, as I explained, you can get GRUB2 persistent failures and Rufus does not enforce anything and instead goes with what the ISO already uses. So can you please address that?
    – Akeo
    Apr 14 '20 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.