5

I have a dual-boot set-up on my computer, Windows + Ubuntu. Additionally I have a secondary hard drive in my computer, formatted as NTFS. Both operating systems are able to access this drive. It's very convenient since I can put all my music, personal files and projects there and access them from both Windows and Ubuntu. On Ubuntu, this drive is mounted on ~/shared.

However Snap applications on Ubuntu are not allowed to access this drive. This includes things like Gimp, VLC, SubtitleEdit and such which access media files that I keep there.

These applications register themselves with the option to access removable drives. I'm giving them this permissions as per this post and they are indeed able to access things in /media such as USB sticks. But not this NTFS partition mounted in my home directory.

I have two workarounds:

  • Uninstall these applications and install them using Apt and such. This works for many applications (like Firefox). The problem is that not all applications are available from Apt or they are sometimes in a lower version.
  • Copy the files I need to access temporarily to my desktop and copy them back when I've edited them. Annoying.

This question is similar, but not quite the same as the following other questions: 1, 2, 3, 4. I wasn't able to find an answer there that worked for this case.

2
  • 1
    Does this answer your question? How to get access to USB-storage from the application installed as Snap? – N0rbert Apr 11 '20 at 22:05
  • No. I did mention in my question that I've given these application permissions to access removable media as per all 3 answers in that link. I've linked that question in my original question twice, even. Most things I could find online linked to that question as it seems to be a common problem, but it did not work here I'm afraid. I tried mount-observe too but that made no difference (and indeed it shouldn't). – Ghostkeeper Apr 12 '20 at 0:19
1

Inkscape was unable to access mounted drives at /mnt/* -- even after setting permissions in Snap Store.

This seemed to work:

sudo snap connect inkscape:removable-media

Ubuntu 20.04.2 LTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.