6

I've been struggling with the gray screen problem of tightvncserver on ubuntu 18.04 and gnome

  • The problem is the same with both aws ec2 as well as my local machine.
  • I've verified that xfcestartup4 works well with tightvnc

Can somebody please clarify once and for all how to make tightvnc work with gnome on ubuntu 18.04?

This is my ~/.vnc/xstartup

#!/bin/bash
export XKL_XMODMAP_DISABLE=1
# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
#startxfce4 &
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
gnome-session &
gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &
gnome-terminal &

I've tried a lot of things but none of them work:

  • uncommenting #exec /etc/X11/xinit/xinitrc
  • using sh after exec
  • using only gnome-session &
  • tried without the ampersand

Please help. Most of the tutorial seems to imply it should work out of the box, but this is utterly not true? Is tightvncserver broken with gnome3?

0

You must log in to answer this question.

Browse other questions tagged .