1

Several days ago my laptop stopped playing or recording sound. I upgraded to Ubuntu 20.04, to no avail.

The Volume Control shows different 'HDMI output' profiles (linked to the NVIDIA TU106 High Definition Audio card) but fails to show any analog sound profiles.

I have two cards:

lspci -v | grep -A7 -i "audio"
00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
        Subsystem: Hewlett-Packard Company Cannon Lake PCH cAVS
        Flags: bus master, fast devsel, latency 32, IRQ 16
        Memory at da210000 (64-bit, non-prefetchable) [size=16K]
        Memory at da100000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>
        Kernel driver in use: sof-audio-pci
        Kernel modules: snd_hda_intel, snd_sof_pci

00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
        Subsystem: Hewlett-Packard Company Cannon Lake PCH SMBus Controller
        Flags: medium devsel, IRQ 16
        Memory at da21c000 (64-bit, non-prefetchable) [size=256]
        I/O ports at efa0 [size=32]
--
01:00.1 Audio device: NVIDIA Corporation TU106 High Definition Audio Controller (rev a1)
        Subsystem: Hewlett-Packard Company TU106 High Definition Audio Controller
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at dc080000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

...but only one is used:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I tried to force the loading of the Intel card driver in /etc/modprobe.d/alsa-base.conf with:

options snd_hda_intel enable=1,0 vid=8086,10de pid=a348,10f9
options snd_hda_intel index=0 vid=8086 pid=a348
options snd_hda_intel index=1

...but no joy.

Could someone help me?

0
0

This post on Ubuntu Forums fixed it for me:

  1. First of all, by looking at the output of cat /proc/asound/card0/codec* it was obvious something was wrong... So first to fix that I had to edit the file /etc/modprobe.d/alsa-base.conf to add the line: options snd-hda-intel probe_mask=0x1 . After reboot, then I could see everything the output of cat /proc/asound/card0/codec* that was looking perfect but still no sound. At least, things had improved a little bit now;

  2. As shown by the output of cat /proc/asound/card0/codec* | grep Codec, my HD Audio Codec is ALC1220 so I went here to look at what specific model that corresponded. My laptop is a clevo laptop ("clevo-p950", in the list), so I added the line options snd-hda-intel model=clevo-p950 to the the /etc/modprobe.d/alsa-base.conf file and rebooted. I thought I had solved it at this point but... nope, still no sound from the speakers or the headphones... but then;

  3. After I posted a bug report, someone suggested that I upgrade my kernel version to at least 5.0. So if you are in this situation where you think you should proceed with a kernel upgrade and it's your first time, don't worry, it's not hard to do at all. I used to build my kernel from source (which can be a long process depending on your machine) but now there's a nice GUI and debian packages to help you out, this tool is Ukuu, see this article for example... In my case and at this moment of writing, after a fresh Ubuntu 18.04 install and update, the kernel version was 4.18.0-22 which was not able to make the "clevo-p950" option work. So I upgraded my kernel to 5.0.2, rebooted and everything started to work! Now my microphone, my headphone and my speakers are all working. This is nice! I hope this can help somebody! Good luck!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.