1

On HP pavilion 14 ce-2851no with Ubuntu 18.04.1 and kernel 5.3.0-46-generic, Intel Wireless-AC 9560 suddenly stops working, it used to work. From Intel I found out that my driver is iwlwifi-9000-pu-b0-jf-b0-34.ucode and it is located in /lib/firmware and the kernel can load it, so I tried:

sudo modprobe -r iwlwifi && sudo modprobe iwlwifi

Even after reboot it cannot be found. I have also Windows 10 installed on the same laptop, the wireless is not working any more there as well, it used to work, I am trying to fix the issue there at the moment as I read somewhere that it might be a hardware problem if I can't fix it in Windows.

Anyone that can help with the issue?

1
  • Consider adding an answer to your question instead of an edit to question itself. – David Apr 11 '20 at 1:19
0

What fixed my problem:

The wireless was not working on windows as well, even after reinstalling the driver from the official source. What fixed the problem was resetting the BIOS settings in BIOS. Now both the Windows and the Ubuntu wireless is working as before. I still don't know the reason for the wireless stop working on the first place.

I will keep my question in case someone needs this solution, I can see that this question Cannot detect wireless driver intel ac wireless 9560 [logs included] is not solved yet and I think it is related but I don't have reputation to be able to answer there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.