10

Description of issue

Boot (or reboot) of machine will load decryption screen Enter the key and continue to boot Black screen displaying just "[20.226612] usci_acpi USBC000:00 PPM init failed (-110)]"

When does this happen?

[Sometimes] When the monitor is connected to the laptop via a usbc to hdmi cable.

[Never] When I remove the cable and wait for the machine to boot "normally" and attach the cable later.

Machine details

  • Fresh install of Ubuntu 20.04 (downloaded beta 10/04/2020)
  • Installed third party drivers as part of install
  • Provided key for third party software and enrolled MDK on first boot
  • Reset UEFI keys from bios prior to install
  • sudo apt update ran on the machine before ever rebooting it
  • Additional drivers: NVIDIA Corporation: TU117M (GeForce GTX 1650 Mobile / Max-Q], "Using NVIDIA driver metapackage from nvidia-driver-440 (proprietary, tested)"
  • Lenovo Thinkpad X1 Extreme (2nd gen)

Notes

What confuses me here is that with the cable plugged it, it only "sometimes" fails to load. Looking into this, people have encountered it on other versions of Ubuntu and what's fixed it for them is to make sure they have the latest NVIDIA drivers installed. I have those from what I can see. Not sure what's causing this problem, especially as it doesn't happen all the time.

In case it is relevant... sometimes when the machine boots, it won't recognise the keyboard plugged in via USB so I have to remove and add the keyboard. This is a regular USB, not USB-C like the display cable.

7 Answers 7

2

I was having the same issue with a Dell Precision 7760, Turned off hybrid graphics in the BIOS and everything booted correctly. BIOS has a note that this setting is not supported by Linux distros.

0
2

Update 24 June 2023: following my 5 steps on my website here seems to work just fine for my laptop.

They are:

  1. Check the BIOS/UEFI settings. Use "Discrete Graphics" instead of "Hybrid Graphics".
  2. Use the latest LTS (Long-Term Support) version of Ubuntu, rather than a short-term support version.
  3. Install the latest non-open-source NVIDIA driver (in Ubuntu's "Software & Updates" app) which works with external monitors and your brightness keys.
  4. Use the X11 window manager, NOT Wayland
  5. Use a USB-C to DP (Display Port) [best], or USB-C to HDMI [ok] video cable, rather than a USB-C to USB-C cable to your monitor.

More details are in the article.

Also try

  1. NVIDIA Settings: change to "Performance mode" instead of "On-Demand" mode.
  2. Manually make your AMDgpu NOT primary (Option "PrimaryGPU" "no"), and your NVIDIA GPU primary (Option "PrimaryGPU" "yes"): Unix & Linux: Mint 19.3 Cinnamon: ucsi_acpi USBC000:00: PPM init failed (-110)

I'm just trying the first option above. If that doesn't work, then I'll try the 2nd option above too.

Update #1: I just did step 1 above, and rebooted. Good sign!: once I rebooted, I had to manually configure the position of my monitors again in the Ubuntu "Displays" settings. This seems promising to me because it makes me think that the display handling for my external monitor may have just been handed over from my internal GPU built into the CPU, to my external NVIDIA GPU, which is probably a good thing for stability, reliability, and functionality of my external monitors and graphics card in Linux.

Update #2: I just tried option 1 above, and it seems to not have fixed it. I'll try bullet 2 above next. See my comment here: https://github.com/NixOS/nixpkgs/issues/36392#issuecomment-1583934335. I am still having issues. Ex: I go to suspend my computer, and I get these errors mentioned at the issue above.

Details

I have a brand new Dell Precision 5570 running Ubuntu 22.04 with X11 (not Wayland) for which I've already done my own recommendations here on my website: Common ways to fix video driver (and related) issues in Linux Ubuntu, but if I leave my computer unplugged then come back to it later, it's still freezing with this information left on the screen and requiring a hard reboot:

ucsi_acpi USBC000:00: failed to re-enable notifications (-110)

enter image description here

Here's the driver I'm using, as selected in "Software & Updates" --> Additional Drivers:

enter image description here

I don't have a "Use “Discrete Graphics” instead of “Hybrid Graphics”" option inside of my BIOS for this computer, but I think it might be related to the computer putting my NVIDIA graphics card to sleep or something, and using the internal graphics card built into the CPU, since it was unplugged and left alone for a bit when the freeze happened. I suspect it probably tried to put the NVIDIA card to sleep, causing this issue.

So, here's what I'm trying next:

Open the NVIDIA Settings GUI --> PRIME Profiles --> change the selection from "NVIDIA On-Demand" (which sounds to me like it might support sleeping the NVIDIA card, which causes problems) to "NVIDIA (Performance Mode)" (which sounds to me like it will keep the NVIDIA graphics card always on, hopefully avoiding this problem. Here are some screenshots:

enter image description here

enter image description here

enter image description here

Then, reboot after making this change.

We'll see if this works. If this doesn't work, then I'll try this answer, as it appears to be manually disabling the internal video card built into the CPU and forcing the NVIDIA card to be primary, and also looks promising: Unix & Linux: Mint 19.3 Cinnamon: ucsi_acpi USBC000:00: PPM init failed (-110)


Note: I'm also tracking some of my progress and issues in the comments under my website article here: https://gabrielstaples.com/common-ways-to-fix-linux-video-driver-issues/

0
1

I also have this issue with the Nouveau driver. I filed a bug for this, please see if you can contribute (like mark as affected):

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1912509

I found some people that reported this being a consequence of using 2 nvme slots. Others wrote about installing Linux firmware. A workaround seems to be to use a pre-5.8 kernel. For me a fresh install with kernel 5.4 works, although I get an occasional freeze.

The hardware is quite new, so the best is to find as much people with this problem that can add info to the bug report. I hope this is a bit helpful, I recommend using the nouveau driver because there is no support from Ubuntu / Canonical on proprietary drivers. You could try to report it to Nvidia if you can pin down the issue to their driver, but I recommend to use only supported drivers to get support from Ubuntu developers.

Also check here for a possible workaround: https://unix.stackexchange.com/questions/587371/mint-19-3-cinnamon-ucsi-acpi-usbc00000-ppm-init-failed-110

1

I had usci_acpi USBC000:00 problem with the new Dell XPS 9500 too. What solved the issue for me was to set the graphic card drivers to the proprietary nvidia drivers. Try to follow this link https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-20-04-focal-fossa-linux

1
  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Jan 24, 2021 at 23:32
1

I had this same issue on ubuntu 21.04, after I installed it and restarted it, this error showed up

Solution: In my case I went to the BIOS and reverted all the settings to 'default' and saved and exited. It worked for me. And after doing this I never had this same issue. Try and let me know if it worked.

1

if after this error system wants username to login and password, you can login with your username and password then enter below command to fix this error:

sudo apt remove gdm3
sudo apt install gdm3

cause of this error is crash of display manager. you can also install the other display manager like lightdm and slim but gdm3 is default of ubuntu and more beautiful.

0

If you're running a laptop with a mux switch, you set it to use only the dGPU, but then set Ubuntu to use only the integrated graphics, you can get this error and fail to boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .