2

I have fresh installed Ubuntu 16.04 and using it only in ssh. I have several nvidia gpu on board.

That is the way how i installed drivers (found info in google):

--------------------------DRIVERS INSTALL--------------------------

Preparing:

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install build-essential libc6:i386

Disable the default Nouveau NVIDIA driver

sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

 Update kernal initramfs

sudo update-initramfs -u
sudo reboot

Downloaded latest driver https://www.geforce.com/drivers

sudo sh NVIDIA-Linux-x86_64-440.83.run
sudo reboot

After that checked by

sudo lspci -vnn | grep -i VGA -A 18

08:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] [10de:1b06] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ZOTAC International (MCO) Ltd. Device [19da:1471]
        Flags: bus master, fast devsel, latency 0, IRQ 140
        Memory at d4000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 2f60000000 (64-bit, prefetchable) [size=256M]
        Memory at 2f70000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 9000 [size=128]
        [virtual] Expansion ROM at d5000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [250] Latency Tolerance Reporting
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [420] Advanced Error Reporting
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

...

--------------------------END DRIVERS INSTALL--------------------------

After that gpus work fine with driver. But

 nvidia-settings
** (nvidia-settings:2285): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-G3kXDTdi54: Connection refused
ERROR: Unable to load info from any available system

First warning solved with help of export NO_AT_BRIDGE=1

About ERROR: Unable to load info from any available system , i found that i need

sudo prime-select nvidia

Info: the current GL alternatives in use are: ['mesa', None]
Info: the current EGL alternatives in use are: ['mesa-egl', None]
Error: the installed packages do not support PRIME
Error: nvidia mode can't be enabled

And now i don't know how to solve all this...

1

In SSH to use nvidia-settings you should use: (set fan for example)

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [gpu:0]/GPUFanControlState=1

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [fan:0]/GPUTargetFanSpeed=75

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.