0

In Kubuntu 19.10, I deleted the default panel that comes with it, and created my own. After doing this, I noticed that hitting the super key no longer launches that KDE menu (the one that allows me to type-search for applications).

Where do I go to remap this super-key as a menu-launcher?

I'm looking under Settings > Shortcuts, but as you can see, I'm having an issue seeing descriptions due to truncation, a fixed narrow pane, and larger than default font-sizes: enter image description here

  • 1
    Press Ctrl+Shift+, to get the older, icon mode rather than the sidebar view which is what you have right now. You'll get more space. If you still can't figure out how to get what you want, we'll go through various options. – DK Bose Apr 10 at 9:29
  • @DKBose : That doesn't seem to work for me. I think, by deleting the default panel, I may have somehow disabled more shortcuts than the one this question is about (the menu launcher via super-key). Perhaps this is why ctrl+shift+, doesn't render the icon-mode you speak of. I'm running KDE 5.16.5. – Lonnie Best Apr 10 at 9:32
  • 1
    Okay, then click on the ☰ to the left of the search box near the top. But that maybe visible only when you first open System Settings, not when you've gone into a specific category. Deleting a panel shouldn't have much consequence. So that shouldn't be a concern. – DK Bose Apr 10 at 9:37
  • @DKBose : ☰ worked at first but as soon as I went to "Shortcuts" it switched back to Sidebar mode. Where is the location of the shortcut that would allow me to re-map my super-key back to the KDE Menu? Super-key stopped working when I replaced the default panel (that comes with KDE) with a custom one (instead of just modifying the default one). – Lonnie Best Apr 10 at 9:44
  • 1
    Is this latte dock? Or what is or where did you get this "custom one" from? I have to be away for about 90 min. – DK Bose Apr 10 at 9:45
0

I got the start menu to launch again by right-clicking on the desktop and then going to Add Panel > Default Panel.

Then, I modified that "default panel" to be like the custom (non-default) panel I created. After that, I deleted the custom panel and placed the modified default panel where the custom one was. After this, the super key began toggling the menu again.

The original reason I deleted the default panel, is because it kept some launchers separate from running tasks (showing redundant icons). Now, I realize that this unwanted behavior can be change by right-clicking on the default panel, then: Edit Panel > Hover over Task Manager Widget > Show Alternatives > select Icons-Only Task Manager.

Anyway, I'm just reporting back here in case someone else has the same oversights I did.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.