1

My circumstances are SSD(CT250MX500SSD1)250GB and external HDD(WD My Passport 25E1)1TB.

I want to install Ubuntu on my external HDD so that I could dual boot it both on my laptop and desktop.

But even that I've installed all partitions and boot loader to the external HDD, the boot menu indicates that I have ubuntu on my SSD, making it impossible to boot my ubuntu in another computer.

partition settings on setup

boot menu

fdisk -l

I've been struggling for days to find out what's the problem but failed due to probably my lack of knowledge on the boot system. I've tried many other things such as making more partitions(/, /boot, /home, /swap) but ended up showing "ubuntu(SATA1:CT250MX...)" and inaccessible via computers. I would really appreciate any help possible.

5
  • I suspect that your bootloader is in the internal drive. It can be moved using instructions by @oldfred. Maybe this link can help you. Otherwise you can unplug or otherwise disable the internal drive and after that install Ubuntu according to this link to get the bootloader in the external drive. (After shutting down you can plug the internal drive back again.)
    – sudodus
    Apr 10, 2020 at 7:07
  • I got the same issues. And I had to install Windows on SSD and Ubuntu on HDD (included swap, /). Then format the remained storage to ntfs to use on both OS.
    – Neo
    Apr 10, 2020 at 7:28
  • 1
    @sudodus thank you so much!! I detached my internal drive and installed ubuntu to my external hdd by partitioning the free space 256MB of EFI system, and the rest to the root. It works perfectly well both on my desktop and my laptop. Would have been struggling for another day if it weren't you.. great thanks for the comments all :)
    – skullmind
    Apr 10, 2020 at 8:20
  • 1
    Please don't add "solved" to the title. If you have found a solution, please post it as answer (or @sudodus can post one)
    – muru
    Apr 10, 2020 at 8:29
  • @skullmind, Thanks for sharing the solution (that you let us know what works for you). It can help other users with the same problem.
    – sudodus
    Apr 10, 2020 at 8:45

1 Answer 1

0

I suspect that your bootloader is in the internal drive. It can be moved using instructions by @oldfred. Maybe this link can help you.

Otherwise you can unplug or otherwise disable the internal drive and after that install Ubuntu according to this link to get the bootloader in the external drive. (After shutting down you can plug the internal drive back again.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .