1

I have a server hosted at a remote data center with Ubuntu 18.04 server installed, the client wanted to login to the server with a GUI, so I installed a desktop manager using apt install ubuntu-desktop I rebooted the server, and apparently no GUI has started, I tried running a few apps that require a display but all of them failed to start.

I tried running startx on the command line (Connected through SSH), but I got this error:

xinit: unable to connect to X server: Connection refused

This was the way I used to install a desktop manager on the previous versions of Ubuntu, and I never ran into any errors.

I requested for a KVM, to see if the system is running the login screen on startup, and it wasn't.

This is what I found in the xorg log file

[   802.741] (WW) Warning, couldn't open module vesa
[   802.741] (II) UnloadModule: "vesa"
[   802.741] (II) Unloading vesa
[   802.741] (EE) Failed to load module "vesa" (module does not exist, 0)
[   802.741] (==) Matched modesetting as autoconfigured driver 0
[   802.741] (==) Matched fbdev as autoconfigured driver 1
[   802.741] (==) Matched vesa as autoconfigured driver 2
[   802.741] (==) Assigned the driver to the xf86ConfigLayout
[   802.741] (II) LoadModule: "modesetting"
[   802.741] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   802.741] (II) Module modesetting: vendor="X.Org Foundation"
[   802.741]    compiled for 1.19.6, module version = 1.19.6
[   802.741]    Module class: X.Org Video Driver
[   802.741]    ABI class: X.Org Video Driver, version 23.0
[   802.741] (II) UnloadModule: "modesetting"
[   802.741] (II) Unloading modesetting
[   802.741] (II) Failed to load module "modesetting" (already loaded, 21889)
[   802.741] (II) LoadModule: "fbdev"
[   802.741] (WW) Warning, couldn't open module fbdev
[   802.741] (II) UnloadModule: "fbdev"
[   802.741] (II) Unloading fbdev
[   802.741] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   802.741] (II) LoadModule: "vesa"

Full Xorg log file can be viewed here: https://pastebin.com/ffKXYrhF I tried multiple suggestions I found online, nothing seemed to work for me, apparently I missed something.

Please advise.

EDIT:

lshw -C display outputs:

  *-display UNCLAIMED
       description: VGA compatible controller
       product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff
0

From the logs, it looks like Xorg driver vesa, fbdev are being attempted. I'd expect a HW-specific driver to be used instead.

Does sudo apt install xserver-xorg-video-intel help at all?

Have you blacklisted any kernel modules for graphics devices via files in /etc/modprobe.d/?

Perhaps check the output from dmesg to determine whether the kernel detected the display device.

  • I did what you said, I still get the same error, I ran dmesg | grep vga and got VGA device added: decodes=io+mem,owns=io+mem,locks=none among other lines. I did not blacklist any modules in /etc/modprobe.d/ Not sure whether the hosting provider did, but running cat /etc/modprobe.d/blacklist* | grep -v '#' | grep blacklist returns many blacklisted modules including intelfb, not sure whether this has anything to do with the display adapter or not. – AL-Kateb Apr 9 '20 at 22:28
  • intelfb sounds like it would be useful... – Stephen Warren Apr 9 '20 at 22:32
  • I will try comment it and see if this helps, meanwhile this is my full xorg log file: pastebin.com/ffKXYrhF – AL-Kateb Apr 9 '20 at 22:34
  • Still the same problem, how do I even know if the desktop manager is running or not? I have no access to the KVM anymore, I'm testing by running startx on the command line while connected through SSH, not sure if this is the proper way of testing it. – AL-Kateb Apr 9 '20 at 22:57
  • You can run ps and/or pstree to see which processes are running. For example, look for an X or Xorg process. If there there no (EE) lines in Xorg.log that's a pretty good sign too. Running DISPLAY=:0 xterm from another ssh session would be a good way to tell if X clients can connect and run. You can CTRL-C it after waiting a few seconds to see if there's any error. – Stephen Warren Apr 10 '20 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.