0

When my computer is running idle with no programs running i can see unusual spikes in the processor and network activity in the system monitor. I has been like this for quite a while. It happens even after a reboot where the only thing I do is starting the system monitor.

I have tried looking for process that uses >10% of the cpu using htop, but I have not found anything.

I am using Ubuntu desktop 18.04.

What can cause this? enter image description here Here is another screenshot. All core are >25% but no application is using anything. It is like the is a hidden process using all the processing power. How is that even possible? enter image description here

5
  • 1
    To start with, which version of Linux have you installed (Ubuntu server, Ubuntu desktop, Kubuntu, Lubuntu, Xubuntu, Ubuntu MATE, et al.) , and which release number? Different releases have different tools for us to recommend. Please click edit and add that vital information to your question so all the facts we need are in the question. Please don't use Add Comment, since that's our channel to you. All facts about your system should go in the Question with edit
    – K7AAY
    Apr 9, 2020 at 21:01
  • 3
    The image you posted probably isn't from a freshly booted system. I see 4 jobs running from /home/peter/.local/sh probably share/something. Unusual. Maybe somebody is bitcoin mining? Please show me an expanded htop image so we can see the entire path. Start comments to me with @heynnema or I may miss them.
    – heynnema
    Apr 9, 2020 at 21:34
  • @heynnema The program in peter/.local/sh was kite. I have now uninstalled it, but it did not help. I have updated the post with a screenshot of full htop after a clean reboot. It seem like the spikes are caused be a program that does not show up in htop
    – Frederik H
    Apr 10, 2020 at 14:27
  • 1
    Install iftop and see what process is using the network. Also show me the result of ps auxc | grep -i therm.
    – heynnema
    Apr 10, 2020 at 15:25
  • @heynnema I tried your commands, which send me on a path of a lot of investigation. Eventually I found out it was a docking station causing the problems. Thanks for the help :D
    – Frederik H
    Apr 11, 2020 at 10:25

1 Answer 1

0

After a lot of investigation I found out it was a Toshiba dynadock universal docking station. When I unplug it and reboot the mysterious CPU activity goes away. And when i replug it the CPU activity starts again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.