0
$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


$ cat /proc/asound/modules

1 snd_hda_intel

$ lspci -v | grep -A7 -i "audio"

00:1f.3 Multimedia audio controller: Intel Corporation Cannon Lake PCH cAVS (rev 10)
    Subsystem: Dell Device 0949
    Flags: bus master, fast devsel, latency 32, IRQ 16
    Memory at a5318000 (64-bit, non-prefetchable) [size=16K]
    Memory at a5000000 (64-bit, non-prefetchable) [size=1M]
    Capabilities: <access denied>
    Kernel driver in use: snd_soc_skl
    Kernel modules: snd_hda_intel, snd_soc_skl, sof_pci_dev


01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at a3080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
3

You will need to add an option on GRUB.

To edit grub options:

sudo nano /etc/default/grub

Find GRUB_CMDLINE_LINUX_DEFAULT and add snd_hda_intel.dmic_detect=0 to the end of it. It will look something like this:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 snd_hda_intel.dmic_detect=0"

Then rebuild grub menu:

sudo grub-mkconfig -o /boot/grub/grub.cfg

After you reboot the system the device should work.

2
  • Thank You! It worked perfectly. – david R Apr 9 '20 at 16:13
  • Wont this basically disable the HD drivers for input ? – Alex Punnen Aug 1 '20 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.