0

I use Ubuntu 18.04 64bit in Oracle VirtualBox, on a Windows 10 PC. I moved with my PC to a different flat. Both before and now I connect to the internet via wifi but of course now I have a different provider. Before I had zero issue with connecting but now I cannot connect (Chrome says "DNS_PROBE_FINISHED_NO_INTERNET"). Wifi works fine in Windows and every other Windows and Android device in the flat, only my virtual Ubuntu is acting up.

When I try anything with apt-get I get these errors:

System error resolving "domainname", (Domain or resource busy)

The after it says "Reading package lists...", the following: W: Failed to fetch and then the same "System error resolving"

It finishes with a message "W: Some index files failed to download."

The following I tried:

  1. Added "nameserver 8.8.8.8" and "8.8.4.4" to the resolv.conf file. Doesn't work, not even temporarily and of course disappears after reboot.
  2. Added the same IPs to the etc/network/interfaces file, it looks like this:
auto lo
iface lo inet loopback
dns-nameservers 8.8.4.4 8.8.4.4 127.X.Y.Z

with the last line being manually added by me, and of course the IP starting with 127. with actual number, the same IP that is in my resolv.conf by default.

  1. Opened Networks in the Settings window, went to IPv4 and added the following IPs under DNS: 8.8.8.8, 8.8.4.4, 208.67.222.222. After I did this, and in the previous ones in god-knows-what order and how many times, apt-get update and upgrade worked once but I get the same exact errors after reboot.
  2. cannot run "resolvconf", it says Command not found, and of course I cannot install it with apt.

Note, getting a wifi connection in itself was quite labourous, I had to add the USB adapter in VirtualBox to my system, and when I boot Ubuntu sometimes it disconnects it automatically and I have to plug the USB out and back to regain Wifi connection. In the list it does say it's connected to the Wifi, but the browser cannot load web pages and apt-get doesn't work.

As for pings: 8.8.8.8 and the likes do not ping, it says "Destination Net Unreachable". The 127.X.Y.Z IP does ping.

Oh, and additional sprinkles: when I boot, I get an *ERROR* Failed to send long, I wonder if it's connected...

I know this is a mess and I already made it worse by trying so many different things, but I feel like I haven't found the solution to my exact problem. Sorry for the long question, I'm very new here and to Ubuntu in general. Thanks in advance.

0

Turns out this was a completely different issue than I expected and had to do with the fact that this is a virtual machine. I use a USB wireless adapter for the PC and I had to uncheck the adapter from the list of USBs in the virtual machine's Configure window, and instead choose bridge adapter in Network and choose the adapter itself from the drop-down list.

Thankfully, all my messing with the .conf files haven't ruined my connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.