I have two laptops with the same ubuntu version, and almost the same software installed. I have been using them lenghtly with the same home wifi and external wifi with no problem of connection of any kind.

From this morning, suddently laptop A have stopped connecting to internet (site can't be reached on chrome, trying forever to open a webpage on Firefox, even ping google.com was returning Name or service not known), despite the wifi status was still connected. Laptop B, was working as usual.

To solve the problem I tried the usual things (restarting the laptop, cleaning cache, killing a couple of processes that I have started when donig web development (e.g. rabbitMQ)...), and none worked.

Then, more out of frustration than anything else, as last option before reinstalling ubuntu, and starting to suspect a virus, I simply restarted the router.

And this, totally unexpectedly, solved the issue. No password was asked, no settings to be changed. Laptop A just re-connected automatically and now it connects to internet flawlessly.

My question is WHY?

How is it possible that restarting the router can solve an issue affecting only one laptop and not the other? And if if happens again, in a situation where I can not restart the router (internet cafe, office...) is there an alternative solution I can try from the computer?


More specs as requested in comments:

Distributor ID: Ubuntu 
Description: Ubuntu 18.04.4 LTS 
Release: 18.04 
Codename: bionic
  • I would rather suspect an intermittent hardware problem on your laptop: sometimes it works, sometimes not. My explananation is that your hardware problem disappeared when you restarted the router, without any relation. Only if restarting the router repeatedly leads to solving the problem, I would think in the direction of the router. Apr 8, 2020 at 8:12
  • Being specific with details can help, Ubuntu 18? Ubuntu releases that use yy are snap based for appliances/devices such as Ubuntu Core 18, where as the standard deb based releases found on desktop & servers are yy.mm in format, such as Ubuntu 18.04 LTS. Are these appliances running Ubuntu Core 18?
    – guiverc
    Apr 8, 2020 at 8:30
  • Here are some more specs: Distributor ID: Ubuntu Description: Ubuntu 18.04.4 LTS Release: 18.04 Codename: bionic
    – SeF
    Apr 8, 2020 at 9:19
  • @Marc Vanhoomissen I would tend to exclude that. As restarting the laptop have not changed anything, and right after restarting the router it worked again, with the first connection. The probability of an hardware glitch are very low... That much of a coincidence is close to impossible.
    – SeF
    Apr 8, 2020 at 9:21
  • 1
    @Sef, when adding new info, do NOT put it in a comment. Instead edit your question to include that info. For clarity, you could put "At request of Marc, here are more specs:" By putting additional info in question, other users only have to look at the Question to see the entire issue and what you did and reported.
    – jpezz
    Apr 8, 2020 at 14:20


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.