1

I try to remove tearing video using custom Intel driver config

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        Option     "AccelMethod" "sna"          # <str>
        #Option     "Backlight"             # <str>
        #Option     "CustomEDID"            # <str>
        #Option     "DRI"                   # <str>
        #Option     "Present"               # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "HWRotation"            # [<bool>]
        #Option     "VSync"                 # [<bool>]
        #Option     "PageFlip"              # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "ReprobeOutputs"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "VirtualHeads"          # <i>
        Option      "TearFree" "True"           # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
    Identifier  "Card0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

I started X session using startx

startx -- -config ./xorg.conf.new -logverbose 6

But I've got the visible artifacts (see img)

I have some visible artifacts when I use custom Intel configuration

Also I send my Xorg.0.log file here

Without the additional Intel configuration Xorg works fine (with tearing) maybe because Xorg loads modesetting_drv.so, not intel_drv.so.

My processor is Intel(R) Core(TM) i5-10210U CPU, only integrated Intel videocard (without NVIDIA and AMD)

But I cannot understand how to solve this problem.

EDIT 1 My notebook is Dell Vostro 3590 Integrated videocard is Intel UHD Graphics 620 (info from here)

Also I ran lspci for VGA controller

aleksey@aleksey-Vostro-3590:~$ sudo lspci -vnnnn | grep VGA -A 16
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:9b41] (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Dell Device [1028:096a]
    Flags: bus master, fast devsel, latency 0, IRQ 138
    Memory at b0000000 (64-bit, non-prefetchable) [size=16M]
    Memory at a0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 4000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [40] Vendor Specific Information: Len=0c <?>
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [100] Process Address Space ID (PASID)
    Capabilities: [200] Address Translation Service (ATS)
    Capabilities: [300] Page Request Interface (PRI)
    Kernel driver in use: i915
    Kernel modules: i915
  • Provide detail on the video card rather than on your processor. Specifying your brand and type of computer also may help users find the specs. – vanadium Apr 7 at 16:41
  • okey, i have filled additional information about notebook and videocard – Aleksey Apr 8 at 3:53
  • Any more info on this? I have the exact same tearing problem on the exact same hardware, using Ubuntu 18.04. – José María Mateos Apr 22 at 17:29
1

I had exactly the same problem and I started testing different things today. In the end, what solved the issue for me (at least on YouTube videos, which is where the error is most noticeable -- for instance here https://www.youtube.com/watch?v=MfL_JkcEFbE) was simply to use compton as whe window compositing engine.

Don't mess with the X11 config. If you're using the modesetting drivers, you're good to go.

Just disable XFCE's compositor, if it's activated, and on a terminal run:

compton --backend=glx

If that solves the issue, make compton start at with every XFCE session. I followed the instructions on this page, but I didn't use their config file, just the glx backend setting.

| improve this answer | |
  • Just FYI there is updated compositor based on compton called picom. – Michal Przybylowicz Apr 22 at 20:13
  • 1
    Thanks for the heads up. For now I'll stick to compton: it fixes the problem and is already installed on my system, but I'll take a mental note. – José María Mateos Apr 23 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.