1

I recently installed Ubuntu 18.04 on my Thinkpad x1 Carbon 7th, the machine worked without a microphone or fingerprint identifier, but apart from that it had no problem. After a click on an updated window, I have two additional problems:

  1. No audio. Sound changed to "dummy" and now audio is not working
  2. Wake up. Computer doesn't wake up, after inactivity moments.

This is the command sequence:

$ uname -r
5.3.0-45-generic

$ aplay -l
aplay: device_list:270: no soundcards found...

$ nano /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Any idea how to fix this ?

2 Answers 2

0

Same problem with my Acer Swift SF514 and Ubuntu 19.10: Kernel 5.3.0-40-generic worked fine Kernel 5.3.0-42-generic has problems with sound. Kernel 5.3.0-45-generic has problems with sound. Kernel 5.3.0-46-generic has problems with sound.

So I installed Kernel 5.3.0-40-generic with: sudo apt-get install linux-image-5.3.0-40-generic and select the right version from the boot menue; still hoping that the next kernel version will do better.

Peter M

0

I find solution. Need manually update linux kernel from https://kernel.ubuntu.com/~kernel-ppa/mainline/

I update to 5.6.3 version and all after update fine.

Steps:

  1. Download generic modules, image and headers
  2. Install from deb packages
  3. Make sudo update-grub
  4. reboot
1
  • Can you give some detailed insights (step by step), on howto change/downgrade the current Kernel back to the previous one, please?!
    – v2r
    Apr 8, 2020 at 0:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .