4

Because of the whole Covid-19-situation I need to be able to use Skype on my relatively new Dell Vostro 5590 laptop. Unfortunately I can't get the webcam to work. It shows me a black screen (in Skype and Cheese and what-have-you). I also installed guvcview, but that hasn't proven useful. It's an integrated HD webcam. I already checked that my user is added to the video group.

Any help is appreciated... Is there a special linux driver that I can install?

Not sure what info to provide, but here is the output of lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0bda:565a Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 8087:0aaa Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And lspci gives

00:00.0 Host bridge: Intel Corporation Device 9b61 (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Device 9b41 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0c)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Device 02f9
00:13.0 Serial controller: Intel Corporation Device 02fc
00:14.0 USB controller: Intel Corporation Device 02ed
00:14.2 RAM memory: Intel Corporation Device 02ef
00:14.3 Network controller: Intel Corporation Device 02f0
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 02e8
00:16.0 Communication controller: Intel Corporation Device 02e0
00:17.0 SATA controller: Intel Corporation Device 02d3
00:1c.0 PCI bridge: Intel Corporation Device 02bc (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device 02b0 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 02b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 0284
00:1f.3 Multimedia audio controller: Intel Corporation Device 02c8
00:1f.4 SMBus: Intel Corporation Device 02a3
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 02a4
01:00.0 3D controller: NVIDIA Corporation Device 1d13 (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Non-Volatile memory controller: Device 1e0f:0001

But I think there's no webcam info in there... Also when I look through the information I get from dmesg | less I see:

[    2.311696] uvcvideo 1-6:1.0: Entity type for entity Realtek Extended Controls Unit was not initialized!

and

[    2.311740] input: Integrated_Webcam_HD: Integrate as /devices/pci0000:00/0000:00:14.0/usb1/1-6/1-6:1.0/input/input6
[    2.311797] usbcore: registered new interface driver uvcvideo
[    2.311798] USB Video Class driver (1.1.1)

But I don't know what I can do with that! Any suggestions? A little note: Ubuntu was not preinstalled on this laptop. I installed it myself.

EDIT: I launched gucview and tried to capture some photos. I got this in terminal:

ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

Thanks and stay healthy!

2

From your "lsusb" output, this is your webcam:

Bus 001 Device 002: ID 0bda:565a Realtek Semiconductor Corp.

So, yes, it is being seen. The Linux Hardware database shows that kernels 3.7 and greater support it. See:

https://linux-hardware.org/index.php?id=usb:0bda-565a

Cool! Ubuntu 18.04 is on kernel 4.15 (or newer if updated) so you are all set there. Hmm. So it looks like the uvc driver should do it out of the box.

Is something blocking your camera from being on? Check the BIOS, any physical switches on your laptop, any keys on the keyboard that turn the camera on or off, or a setting in gnome settings.

In addition, you can install v4l-utils.

sudo apt install v4l-utils

more info: https://launchpad.net/ubuntu/+source/v4l-utils

This is a bunch of command line tools to test out your camera. The command "qv4l2", for instance, will launch a detailed and somewhat complex program for testing your camera. Could get you somewhere.

Best

2
  • that was a very helpful reply, but unfortunately the problem persists. The cam light pops on when I try to use it, but the screen it shows me is black. Apr 5 '20 at 18:19
  • Well that's something. Are any of the solutions here helpful?: askubuntu.com/questions/461657/… be wary of any overly complicated solutions, try to simple stuff first.
    – Smoking
    Apr 7 '20 at 1:51
1

For me (Lenovo IdeaPad running Ubuntu 18.04 as guest under VMWare) the USB emulation has to be set to 3.0 then the camera worked.

1
  • This worked like a charm in my case too: ubuntu 18.04 guest on vmware workstation 15 pro on windows 7 host. VM Settings --> USB compatibility -> Change from the defaulted 2.0 to 3.0; the VM gets restarted upon this change (takes a couple of minutes). Note(1): Make sure the Webcam is working on the host Note(2): Make sure the VM can "see" the webcam [VM bottom right --> Click on the icon corresponding to the Webcam --> Connect (Disconnect from host)]. Aug 21 at 14:09
0

Check if there is some kind of switch to activate the webcam, like the keys: fn + CAM. If there is not, look if there is some physical switch on the side of the notebook. If there is none, try to find in the BIOS options if there is some set to activate the camera. Some DELL models have a panel called "Miscellaneous Devices".

2
  • the webcam is enabled in BIOS and there are no physical switches... Apr 5 '20 at 17:46
  • Do you have another OS like Windows on the same machine? If yes, the camera works ok on that OS? It seems that it is a hardware problem of some kind. Maybe silly, but check the lenses, if there is something blocking the camera.
    – Jonatã
    Apr 7 '20 at 3:38
0

For my Dell latitude Laptop, i have disabled secure boot by pressing F2 on boot menu. Tested using cheese and worked.

chinhx@chinhx-Latitude-7280:~$ ls -la /dev/video* crw-rw-rw-+ 1 root video 81, 0 Jul 6 16:38 /dev/video0 crw-rw-rw-+ 1 root video 81, 1 Jul 6 16:38 /dev/video1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.