10

Question says it all, emacs 27 doesn't seem to be available through apt-get on my ubuntu version nor PPAs. Does that mean I have to build it from source? Thank you.

2
  • 1
    snapcraft.io/emacs shows 26.3 from the stable channel, 27.0.90 from beta, and 28.0.50 from edge channels.
    – guiverc
    Apr 5, 2020 at 7:27
  • @guiverc ah, is that what the snap installing thing uses? I will look into it, thank you
    – Jose V
    Apr 5, 2020 at 7:38

2 Answers 2

6

Here's how I compiled it from source on Ubuntu 16.04 (there's also instructions in the Emacs documentation):

# https://stackoverflow.com/questions/338317/what-is-makeinfo-and-how-do-i-get-it
sudo apt install --yes texinfo
# https://stackoverflow.com/questions/55297581/build-emacs-ubuntu-libraries-not-found
sudo apt install --yes libxpm-dev libjpeg-dev libgif-dev libtiff-dev libgnutls28-dev

git clone https://git.savannah.gnu.org/git/emacs.git /tmp/emacs \
    && cd /tmp/emacs \
    && git checkout emacs-27 \
    && ./autogen.sh && ./configure && make \
    && mv ./src/emacs /usr/bin/emacs \
    && rm -rf /tmp/emacs

Also, if you want to use Doom Emacs, you'll also need:

# rg
# https://github.com/BurntSushi/ripgrep/releases
curl -LO https://github.com/BurntSushi/ripgrep/releases/download/11.0.2/ripgrep_11.0.2_amd64.deb \
    && sudo dpkg -i ripgrep_11.0.2_amd64.deb \
    && rm ripgrep_11.0.2_amd64.deb
# fd
# https://github.com/sharkdp/fd/releases
curl -LO https://github.com/sharkdp/fd/releases/download/v8.1.1/fd-musl_8.1.1_amd64.deb \
    && sudo dpkg -i fd-musl_8.1.1_amd64.deb \
    && rm fd-musl_8.1.1_amd64.deb

git clone --depth 1 https://github.com/hlissner/doom-emacs ~/.emacs.d
~/.emacs.d/bin/doom install
5
  • I've to run make install to get the doom part working
    – Āchahms
    May 19, 2021 at 12:13
  • @Āchahms "I've" doesn't work the way you are using it.
    – Boris
    May 19, 2021 at 12:23
  • do you think it has to do with su mode or something, i was trying to run all this in su shell. sorry completely new to debian/linux
    – Āchahms
    May 20, 2021 at 6:17
  • the error i was getting: Warning: arch-dependent data dir '/usr/local/libexec/emacs/27.2.50/x86_64-pc-linux-gnu/': No such file or directory
    – Āchahms
    May 20, 2021 at 6:23
  • And maybe add sudo apt install libjansson-dev to get native JSON support compiled in
    – Dilettant
    Jun 11, 2021 at 10:41
5
snap install emacs --beta --classic
2
  • yeah this worked, i had to install emacs26 from the PPA for the snap to work though.... more info here github.com/alexmurray/emacs-snap/issues/11
    – Jose V
    Apr 6, 2020 at 4:02
  • ok so since I had emacs26 installed I had to clean emacs config, since I was using doom-emacs this meant delete ~/.emacs.d/.local then run doom sync to reinstall. Then it worked without emacs26
    – Jose V
    Apr 10, 2020 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.