0

I am trying to use Lubuntu 18.04 to connect over remote desktop connection to a server. Each time I want to log in I am sent an auto generated .rdp file. However, remmina fails to connect using this RDP file. It contains the following:

full address:s:[THE ADDRESS]
gatewayaccesstoken:s:xloMy1x7gjJoJV4UWSzGww
gatewaycredentialssource:i:5
gatewayhostname:s:[THE GATEWAY HOSTNAME]
gatewayprofileusagemethod:i:1
gatewayusagemethod:i:1
server port:i:3389
signature:s:[A SIGNATURE]
signscope:s:Full Address,Server Port,GatewayHostname,GatewayUsageMethod,GatewayProfileUsageMethod,GatewayCredentialsSource

I have put the certain things in square brackets for security reasons. Could anybody give me some pointers as to why this isn't working with Remmina 1.4.1. I have no issue with connecting from Windows 10 to this server using Windows Remote Desktop Connection and the same files.

0

I have used Remmina to connect to Windows computers before. First, make sure that remote desktop is properly enabled on the server via the window "Allow an App or feature through windows firewall". Make sure both Network discovery and Remote Desktop are enabled for domain, or private as applies to your situation. On Remmina, it should be sufficient to simply specify the server as shown:

Profile

Name: Clear name, for your recognition

Protocol: RDP

Basic

Server: fully qualified domain name

Username: admin user that has access to connect to the server

User password: admin password

Domain: domain name

I use this all the time for connecting to the computers that we service. I have not had to use anything more complicated. I don't believe I have been prompted with an autogenerated RDP file for any connection, nor have i added any files to the connection. If you require the SSH key, copy it to your computer ahead of time before you try to remotely connect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.