Last evening I made the requested packages upgrade for Ubuntu 18.04.4 Desktop. But now I'm not able to connect to the network anymore with the previous network configuration files. These are the packages upgraded:

enter image description here

Here's the NetworkManager.conf file content:

$ sudo nano /etc/NetworkManager/NetworkManager.conf




Following these indications: No wired connection - Wired unmanaged ubuntu 18.04

I tried to put managed=true in /etc/NetworkManager/NetworkManager.conf and run

sudo service network-manager restart

followed by a system reboot.
But the problem still persists.

Modifying the 01-network-manager-all.yaml file:

$ sudo nano /etc/netplan/01-network-manager-all.yaml
#Let NetworkManager manage all devices on this system
  version: 2
  #renderer: networkd
      dhcp4: no
      addresses: []
        addresses: [,]


  version: 2
  renderer: NetworkManager
  #renderer: networkd
      dhcp4: trye
      #dhcp4: no
      #addresses: []
      #  addresses: [,]

made the wired connection working again.

What happened due to this Ubuntu 18.04 package upgrade?

  • Status please... – heynnema Apr 5 at 12:58


Edit /etc/NetworkManager/NetworkManager.conf and change "managed" back to false.

Assure that /etc/network/interfaces only contains the following active lines:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Set your /etc/netplan/01-network-manager-all.yaml back to:

  version: 2
  renderer: NetworkManager

sudo netplan --debug generate

sudo netplan apply


Then configure your wired connection using the NetworkManager GUI.

| improve this answer | |
  • I checked everything and it corresponds to what I've already set. Anyway, thanks for these guidelines – user2315094 Apr 6 at 11:09

The /etc/netplan/01-network-manager-all.yaml file that you posted is not the default netplan configuration that is provided by the Ubuntu desktop installer. The most likely explanation for this behavior is that you edited (with an editor or through some software) this file, and after applying the latest updates you rebooted, causing Network Manager to respect the new config which told it not to manage the wired ethernet interface.

| improve this answer | |
  • As far as I know I didn't do any thing, apart from upgrading the ubuntu packages – user2315094 Apr 6 at 11:08

I've experienced something very similar. Everything was working fine until I ran an update yesterday. Now the SMB mounts ive specified in fstab wont work properly as they used to and every so often my wired connection will fail.

| improve this answer | |
  • 1
    This is really a comment, not an answer. Please fix this, and delete this answer. Thanks! – heynnema Apr 4 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.