0

This is the output of sudo fdisk -l /dev/sdb

Disk /dev/sdb: 111.8 GiB, 120034123776 bytes, 234441648 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 33553920 bytes Disklabel type: dos Disk identifier: 0x000c918a

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sdb1            8192   3685546   3677355  1.8G  e W95 FAT16 (LBA)
/dev/sdb2         3685547 234441647 230756101  110G  5 Extended
/dev/sdb5         3686400   3751933     65534   32M 83 Linux
/dev/sdb6         3751936   3899389    147454   72M  c W95 FAT32 (LBA)
/dev/sdb7         3899392 121831421 117932030 56.2G 83 Linux
/dev/sdb8       121831424 122879997   1048574  512M  c W95 FAT32 (LBA)
/dev/sdb9       122880000 234441647 111561648 53.2G 83 Linux

Now I am able to mount the sdb8, sdb6 , sdb1

but not the rest and get below errors:

$ sudo mount /dev/sdb7 /mnt/ssd -t vfat
mount: /mnt/ssd: wrong fs type, bad option, bad superblock on /dev/sdb7, missing codepage or helper program, or other error.

$ sudo mount /dev/sdb9 /mnt/ssd -t vfat
mount: /mnt/ssd: wrong fs type, bad option, bad superblock on /dev/sdb9, missing codepage or helper program, or other error.
0

sdb7 and sdb9 are not FAT partitions so just drop the “-t vfat” from the commands you have used and it should work.

| improve this answer | |
  • should I use this : /dev/sdb7 /mnt/ssd defaults,noatime,nofail,x-systemd.automount 0 2 -o uid=1000 in /etc/fstab ? – Ciasto piekarz Apr 4 at 10:09
  • You need something like “ /dev/sdb7 /mnt/ssd ext4 defaults 0 2 “. The ext4 item assumes your file system is ext4. Adjust to match your disk if necessary. Adding noatime will stop recording read access times which can be quicker if that’s an issue for you. Adding no fail is probably only relevant if it’s an external disk. x-systemd.automount will delay mounting until the disk is requested. That can in theory speed up boot times and is more relevant to a very large disk – PonJar Apr 4 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.