I'm using simple-scan with a Brother DCP-L2530DW printer/scanner. The printer works fine, but I'm having issues using the scanner.

I've installed the drivers:

jam@jam-ncase:~$ sudo dpkg -l | grep Brother
[sudo] password for jamie: 
ii  brscan-skey                                0.2.4-1                                amd64        Brother Linux scanner S-KEY tool
ii  brscan4                                    0.4.8-1                                amd64        Brother Scanner Driver
ii  dcpl2530dwpdrv:i386                        4.0.0-1                                i386         Brother DCP-L2530DW printer driver (lpd/cups)
ii  printer-driver-brlaser                     5-1                                    amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                      1.4.2-3                                amd64        printer driver Brother P-touch label printers

When I start simple-scan, it says Ready to Scan - Brother DCP-L2530DW.

But when I click scan, the scanning animation starts, but then an error message pops up saying: Failed to scan, unable to connect to scanner.

I've googled the problem, and the things I've tried are:

  • add my user to lp

  • Running this command: sudo cp /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane

  • Please update your post with the version of Ubuntu you were using when you wrote this. The bug mentioned by @Boorhin affects 20.04, but I'm having a similar problem to yours using 18.04. Knowing your version will help determine the source of our errors. Jul 26, 2022 at 12:26

1 Answer 1


This did the trick on Ubuntu 20.04 for a brother MFC-L2710DW

sudo apt purge ippusbxd

references https://bugs.launchpad.net/hplip/+bug/1871011


  • Please update your answer with 1) the version of Ubuntu you were using when this solution worked and 2) the brand of printer/scanner you were using. This will help me determine if the bug you've linked might be relevant to my 18.04 system using a Brother scanner. Jul 26, 2022 at 12:29
  • Edited my answer
    – Boorhin
    Aug 1, 2022 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.