I have a laptop Dell Inspiron 14R N4010 with ATI Radeon HD 5650. I tried to install the right driver (from version 11.11 to 12.2) but when I get to the part of generating a newer version of the Xorg config file it shows this message: "aticonfig: No supported adapters detected"

How can I solve this?

Edit: I follow all instructions I found here: Gnome-shell does not display top toolbar panel using a Mobility Radeon 5650

  • Please edit your question and specify the version of Ubuntu you are using? – Basharat Sialvi Apr 24 '12 at 5:36
  • could you possibly add the commands your using (and if root)? as well as the version of ubuntu. I believe they're up to 12.3 now so that may fix your issue – MuffinStateWide Apr 24 '12 at 6:38
  • I followed a tip from another page to solve my problem and then I did what @MuffinStateWide told me and try with 12.3 but now I get another error "aticonfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory" – Cesar Apr 24 '12 at 23:14


Here's what you need to do:

  1. Download driver for the AMD web page at http://ati.amd.com/
  2. Open Terminal window
  3. Go to folder where your driver is placed, or move it to your Home directory
  4. ls
  5. sh amd-driver-installer-12-1-x86.x86_64.run
  6. Then the dialog box will apear
  7. Follow the instuctions to install the driver
  8. Enjoy!
| improve this answer | |
  • that's the way I tried and doesn't work to me – Cesar May 29 '12 at 19:41

I'm sorry my knowledge cant help you much more but, this method has not failed for me

first you'll need to uninstall fglrx by typing into the terminal ./usr/share/ati/fglrx-uninstall.sh.then you should reboot.secondly get your drivers from here remembering you want the mobile HD 5 series for 32 (x86) or 64 bit in this case.

when they finish downloading , you'll usually need to add execute permissions then execute the script.

when it loads i choose Install over xorg (usually 6.8) or later i find problems occur when using the build package option. it should finish with no problems then you should check the log the directory will be given to you when the installer ends (even if it fails)

if everything is ok then run sudo aticonfig --initial

i suspect we can further pinpoint the problem with parts of the install log, which now come to think of it i think is located at /usr/share/ati/fglrx-install.log

even if it fails you'll need to reboot before you can remove the drivers.if you don't intend to do GPU intensive tasks however the open source drivers should suffice and they will come in system updates from update manager

| improve this answer | |
  • I'll try and tell you – Cesar Apr 27 '12 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.