0

I have Ubuntu 16.04.6 LTS (GNU/Linux 5.4.10-x86_64-linode132 x86_64) Try to update to 18 but get some errors. When i make do-release-upgrade i get

An unresolvable problem occurred while calculating the upgrade.

This was likely caused by: * Unofficial software packages not provided by Ubuntu Please use the tool 'ppa-purge' from the ppa-purge package to remove software from a Launchpad PPA and try the upgrade again.

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log' and 'apt.log'.

grep Broken /var/log/dist-upgrade/apt.log

Broken systemd-sysv:i386 Conflicts on systemd-shim [ i386 ] < 9-1bzr4ubuntu1 > ( admin ) Broken systemd-sysv:i386 Conflicts on upstart-sysv [ i386 ] < 1.13.2-0ubuntu21.1 > ( admin ) Broken systemd:i386 Conflicts on upstart [ i386 ] < 1.13.2-0ubuntu21.1 > ( admin ) Broken imagemagick-6-common:i386 Breaks on libmagickcore-6.q16-2 [ i386 ] < 8:6.8.9.9-7ubuntu5.15 > ( libs ) (< 8:6.9.6.2+dfsg-3~) Broken perl:i386 Depends on perl-modules-5.26 [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) (>= 5.26.1-6ubuntu0.3) Broken libperl5.26:i386 Depends on perl-modules-5.26 [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) (>= 5.26.1-6ubuntu0.3) Broken libdpkg-perl:i386 Depends on perl [ i386 ] < none -> 5.26.1-6ubuntu0.3

( perl ) Broken dpkg-dev:i386 Depends on perl:any [ any ] < none -> > ( none ) Broken poppler-data:i386 Breaks on gs-cjk-resource [ i386 ] < 1.20100103-3 > ( text ) (<= 1.20100103-3) Broken libalgorithm-merge-perl:i386 Depends on perl [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) Broken libalgorithm-diff-xs-perl:i386 Depends on perl [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) (>= 5.26.1-4) Broken libfile-fcntllock-perl:i386 Depends on perl [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) (>= 5.26.0-4) Broken libalgorithm-diff-perl:i386 Depends on perl [ i386 ] < none -> 5.26.1-6ubuntu0.3 > ( perl ) Broken pkg-config:i386 Depends on dpkg-dev [ i386 ] < none -> 1.19.0.5ubuntu2.3 > ( utils ) Broken build-essential:i386 Depends on dpkg-dev [ i386 ] < none -> 1.19.0.5ubuntu2.3 > ( utils ) (>= 1.17.11) Broken libdbus-1-dev:i386 Depends on pkg-config [ i386 ] < none -> 0.29.1-0ubuntu2 > ( devel ) Broken libglib2.0-dev:i386 Depends on libpcre3-dev [ i386 ] < none -> 2:8.39-9 > ( libdevel ) (>= 1:8.31) Broken python-dbus-dev:i386 Depends on libdbus-1-dev [ i386 ] < none -> 1.12.2-1ubuntu1.1 > ( libdevel ) (>= 1.6) Broken libharfbuzz-dev:i386 Depends on libglib2.0-dev [ i386 ] < none -> 2.56.4-0ubuntu0.18.04.6 > ( libdevel ) (>= 2.19.1) Broken libmagickwand-6.q16-2:i386 Depends on libmagickcore-6.q16-2 [ i386 ] < 8:6.8.9.9-7ubuntu5.15 > ( libs ) (>= 8:6.8.9.9) Broken libmagickcore-6.q16-2-extra:i386 Depends on libmagickcore-6.q16-2 [ i386 ] < 8:6.8.9.9-7ubuntu5.15 > ( libs ) (>= 8:6.8.9.9) Broken python3-zope.hookable:i386 Depends on python3 [ i386 ] < 3.5.1-3 -> 3.6.7-1~18.04 > ( python ) (< 3.6) Broken libicu-le-hb-dev:i386 Depends on libharfbuzz-dev [ i386 ] < none -> 1.7.2-1ubuntu1 > ( libdevel ) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel ) Broken icu-devtools:i386 Breaks on libicu-dev [ i386 ] < 55.1-7ubuntu0.5 -> 60.2-3ubuntu3.1 > ( libdevel ) (< 60.2-3ubuntu3.1) Broken libicu-dev:i386 Depends on libicu-le-hb-dev [ i386 ] < none -> 1.0.3+git161113-4 > ( libdevel )

What i should do with it? Please help

  • 1
    What of this don't you understand? "This was likely caused by: * Unofficial software packages not provided by Ubuntu Please use the tool 'ppa-purge' from the ppa-purge package to remove software from a Launchpad PPA and try the upgrade again." – pLumo Apr 2 at 13:17
  • 1
    Does this answer your question? How can PPAs be removed? – pLumo Apr 2 at 13:17
  • 2
    There are two supported kernels for Ubuntu 16.04, neither is 5.4, so your first line shows you're not using a supported kernel (thus that package itself may stop upgrade) so I don't need to go beyond a few words into your description for the first obvious possible blocking package. To make it work 3rd party packages should be removed (eg. PPA's) plus packages intended for later releases etc...) – guiverc Apr 2 at 13:20
  • @pLumo, sorry but realy can't get it. I removed all PPA by this method: askubuntu.com/questions/646884/how-can-i-remove-all-ppa if i make sudo ls /etc/apt/sources.list.d there are no any files with PPA_XXX – Viktor Kushnir Apr 2 at 14:03
  • And now if make do-release-upgrade i get Could not calculate the upgrade An unresolvable problem occurred while calculating the upgrade. If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log' and 'apt.log'. – Viktor Kushnir Apr 2 at 14:07
0

There are many ways to solve this issue , if you want to upgrade but can't:

Way 1

Step 1 : open Software & Updates.

Step 2 : change Download from to Main Server

Step 3 : open Terminal (ctlr + alt + t) then sudo apt-get update , then sudo apt-get upgrade

Way 2 Remove PPA

Step 1 : open Software & Updates.

Step 2 : go to Other Software tab and choose the desire PPA from the list. Afterwards click on Remove to remove it.

OR

You can remove it using terminal : sudo apt-add-repository -r PPA_Name/ppa

Way 3 :

Read This

also try to use this commands , may it help: sudo apt clean , sudo apt autoclean , sudo apt autoremove.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.