1

I'm manually sorting a whole load of data files at the moment in Thunar (1.6.15), in preparation for running a script over them, so my filename convention has to be spot on, though they were saved manually.

Checking the filenames is made harder by the variable-width characters use in the (detailed) file list view. Is there a way to set a monospaced font? Ideally I'd use one with very good character differentiation (as I'd get in a terminal, or an editor set up for programming)

  • Can't you do that from Thunar's preferences? Monospace, for example, should be available. I like Hack. – DK Bose Apr 2 at 8:43
  • @DKBose I also use Hack for editing, but there are no font settings at all in Thunar's preferences or the Thunar section of XFCE's Settings Editor – Chris H Apr 2 at 9:00
  • I'm very sorry! It's quite surprising. In that case, you'll have to bit the bullet and change fonts globally via Appearances. Change the proportional font to Hack. That works. I just checked. Once you've done your work, you can revert. – DK Bose Apr 2 at 9:51
  • You can also do so via Settings Editor > xsettings and double-click FontName and enter the font you want in place of the existing one in the value box to, say, Hack 11. – DK Bose Apr 2 at 9:56
  • @DKBose at least it works instantly and without restarting anything. My own further reading suggests a possible approach via GTK+ and CSS but I don't have time to experiment with it now – Chris H Apr 2 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.