2

I have recently installed Ubuntu 18.04 for the very first time. Unfortunately, I am having problems with the brightness controls in Linux. What further compounds my problem is that I have not found any posts that have helped with my current predicament.

Here's what doesn't work:

  • The brightness slider. It is there, and I can slide it around, though nothing happens to the brightness.
  • xbacklight. I have also installed xbacklight in an attempt to change the brightness. However, no matter what value I set the brightness to, my real screen brightness stays at 100%. If I set it to 0%, it does completely dim my screen, but if I set it to 1%, -get outputs "1", though my real screen brightness is still at 100%.
  • The fn keys for brightness are a bit glitchy. The default keys for brightness control are fn+f5 (to increase brightness) and fn+f6 (to decrease it). Attempting to increase brightness has a chance of increasing the volume of my internal microphone (upon inspection of keyboard shortcut settings, I have found no control options for microphones), and attempting to decrease it brings about a chance to mute my internal microphone.

Here's what I've tried:

  • Editing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"in /etc/default/grub. I have also previously set the value of acpi_backlight to video, to no avail.
  • sudo-prime intel
  • Altering /usr/share/X11/xorg.conf.d/80-backlight.conf with the following content:

    Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "sna" Option "Backlight" "acpi_video0" BusID "PCI:0:2:0" EndSection

  • Altering /usr/share/X11/xorg.conf.d/20-intel.conf with the following content:

    Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

  • Changing my "Additional Drivers" settings to as depicted in the image here (Essentially, using nvidia-driver-435 and not using Intel).

My Laptop's specifications:

  • Lenovo Legion Y740
  • Intel® Core™ i7-9750H CPU @ 2.60GHz × 12
  • Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)
  • NVIDIA RTX 2060

It would help me tremendously should somebody have a working solution to my problem, as the brightness gets quite intrusive at night. I would really appreciate any suggestions I can get, and I apologize for my really long post.

2
  • Welcome to AskUbuntu, does this help? askubuntu.com/questions/1029283/… – Sadaharu Wakisaka Apr 2 '20 at 2:56
  • 1
    The brightness controller is able to dim the screen! Though it would be nice if I could change the brightness with my function keys, I thank you very much for your reply! – TimothyAxel Apr 2 '20 at 4:09
0

This can be achieved with the GNOME shell extension Adjust Brightness Icon.

Install GNOME extensions if you have not already done so and select the extension. This will place an icon on the top bar which allows you to cycle through different settings of brightness.

enter image description here

If you don't have GNOME extensions installed this guide provides a handy reference.

1
  • 1
    Thanks for the workaround! – TimothyAxel Apr 2 '20 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.