0

My mouse pointer moves by itself automatically at either 10 - 15 minutes intervals or less. Im on the Ubuntu 18.04.4 LTS, Laptop = Toshiba Portege Z30-A. Is there a way I can stop this from happening?

Please help.

Regards,

Mark

0

Most likely it's caused by the pointing stick in the middle of your keyboard. Many people have reported this problem in both Windows and Linux.

You can disable it.

To summarize the link, first list your devices:

$ xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint TouchPad          id=11   [slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                         id=14   [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS DualPoint Stick             id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ TOSHIBA Web Camera - FHD                  id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ Toshiba input device                      id=13   [slave  keyboa

Then disable the pointing stick:

$ xinput disable 12

substitute 12 with your pointing stick device ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.