0

When I'm trying to run "sudo apt-get update" on ubuntu 18.04 LTS, I'm getting error in below comments:

Hit:1 http://in.archive.ubuntu.com/ubuntu bionic InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                         
Hit:3 http://in.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                   
Hit:4 http://in.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                 
Hit:5 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                                                                                      
Hit:6 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu bionic InRelease                                                                     
Ign:7 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04  InRelease                                                              
Hit:8 http://dl.google.com/linux/chrome/deb stable Release                                                                                           
Err:9 http://download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04  Release                                                                
  404  Not Found [IP: 2620:113:80c0:8::13 80]
Hit:10 http://deb.playonlinux.com trusty InRelease                                                                                                   
Hit:11 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                                                   
Hit:12 http://ppa.launchpad.net/slgobinath/safeeyes/ubuntu bionic InRelease                                                      
Hit:14 https://download.sublimetext.com apt/stable/ InRelease                                                  
Hit:15 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease                                       
Hit:16 http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu bionic InRelease        
Reading package lists... Done                       
E: The repository 'http://download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04  Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I have tried below links, but nothing worked. apt- sudo apt-get update not working! "sudo apt-get update" is not working

Please help me in resolving the error!

3
3

You can change the repository that figures there

http://download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04

,that dont have a release file for this one:

http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04/

If that doesn't work, you should delete that repository, i tried to enter there and i found that it donest exist anymore(the version is no longer supported), sor you could try the 18.04 or delete the first

You can search a way to add repositories searching on google how do that for you SO(i think that is Xubuntu 16.04)

2
  • Yes, both of the repositories don't exist. I tried to remove the repository(Software & update > Other Software > Select the link > Remove > Close) in the error i.e., download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04 and it solved the problem. Hence, sudo apt-get update is running fine now. But I am thinking how do I know which repositories should be added to that list. Are there any standards/ general repos? – Brijesh Apr 3 '20 at 7:15
  • Yes, there are "official" repositories for each distribution, and they would have "mirrors" from different contries. I suggest you search in google mirrors that are near to your country(.in is from india i think), and try to get them. I give here an example of some US. mirros, and a description that gives you some idea of the structure of the type of repositories you will find: gist.github.com/rhuancarlos/c4d3c0cf4550db5326dca8edf1e76800 – Munsko Apr 3 '20 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.