Flash does not work in any browser. Xubuntu 11.10. I've looked everywhere, I've tried flash-aid, I've placed the flash file manually, nothing works. Midori, chromium, iceweasel, firefox, w/e. Reinstalled many times, rebooted countless ones, I've been trying for three days now.

What am I supposed to do? I am lost. Flash is essential for me. Soon to reach the breaking point and switch.


dpkg -l | grep -i flash

ii adobe-flash-properties-gtk GTK+ control panel for Adobe Flash Player plugin version 11 
ii adobe-flashplugin Adobe Flash Player plugin version 11 
rc flashplugin-installer Adobe Flash Player plugin installer
  • What is the output to dpkg -l | grep -i flash ? – jippie Apr 15 '12 at 15:58
  • ii adobe-flash-properties-gtk GTK+ control panel for Adobe Flash Player plugin version 11 ii adobe-flashplugin Adobe Flash Player plugin version 11 rc flashplugin-installer Adobe Flash Player plugin installer – Jonas Apr 15 '12 at 16:03
  • Is shockwave flash version 11.2 r202 in your about:addons in firefox? – jippie Apr 15 '12 at 16:22

There are some problems with the new version, the 11.2 one. What I did was this (in a terminal):

  1. Downloaded: wget http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.159.1-0natty1_i386.deb
  2. Installed it with `sudo dpkg -i adobe-flashplugin_10.2.159.1-0natty1_i386.deb'
  3. And opened sudo synaptic to force the version. synaptic

This will do the trick. OR

  1. Download http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.159.1.orig.tar.gz
  2. Copy the libflashplayer.so to /usr/lib/flashplugin-installer/
  • Your solution worked. :) Thank-you very much. – Jonas Apr 15 '12 at 16:40
  • Keep in mind that this is not the best solution, but it works. Later you might need to install the 11.2 version. – gajdipajti Apr 15 '12 at 16:43
  • The first command assumes use of an i386 system. I would add links for amd64, also. – hexafraction Aug 13 '12 at 16:55

Looks like Adobe's flash-plug-in doesn't work anymore for Firefox on Ubuntu. Have you tried gnash plug-in for Firefox ? Or tried installing in Google-chrome(not Chromium)?

  • Just patched my Kubuntu last evening and flash is working fine for me. OK, I'm running Kubuntu, not Xubuntu. – jippie Apr 15 '12 at 16:29
  • you mean working with Adobe's plug-in? or gnash one? – Samik Apr 15 '12 at 16:34
  • Shockwave Flash File: libflashplayer.so Version: Shockwave Flash 11.2 r202 MIME Type Description Suffixes application/x-shockwave-flash Shockwave Flash swf application/futuresplash FutureSplash Player spl – jippie Apr 15 '12 at 16:38

The first answer worked for me. I would suggest removing the non-working Flash first. In Terminal: sudo apt-get remove flashplayer

  • This is better as a comment. Also, please format your code accordingly with backticks around it as follows: not code `code` not code – hexafraction Aug 13 '12 at 16:52

I had the same problem with Flash 11.2, but Flash 11.1 works, and it's available from adobe's website. It's quite a big file, but in that zip is a .tar.gz which contains the 11.1 version of libflashplayer.so, which you can copy to /usr/lib/mozilla/plugins. (Then restart firefox)


Please note that wget http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.159.1-0natty1_i386.deb gives an error 404 (Seems to be removed from the server)

Only the second solution works : Download http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.2.159.1.orig.tar.gz Copy the iin libflashplayer.so to /usr/lib/flashplugin-installer/

Note that the problem is related to the type of cpu you have. dpkg -l | grep -i flash ii flashplugin-installer Adobe Flash Player plugin installer is working ok on some of my computers, but fails to work on a pc with the following processor-type

cat /proc/cpuinfo processor : 0 vendor_id : AuthenticAMD cpu family : 6 model : 6 model name : AMD Athlon(tm) XP 1600+ stepping : 2 cpu MHz : 1404.763 cache size : 256 KB fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 1 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up bogomips : 2809.52 clflush size : 32 cache_alignment : 32 address sizes : 34 bits physical, 32 bits virtual power management: ts

Replacing the new library with the older version helps on this type of computer.

See also : https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/968759

With the most recent package Firefox did nothing when trying to open video's or Google Streetview. Chromium reported an error in libflashplayer. After replacing the new library with the older one, Firefox is working ok. Chromium gives a warning that the flashplayer is outdated, but if you ignore this warning Chromium is working ok again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.