0

After installing new router with ubuntu 18.04 on it i'm got a problem with working ospf via gre tunnel to my older routers. All configured simular, but from new router i got ospf state Init/DROther. Older routers (without netplan) dont see any neighbor. Tunnels work fine with static routing.

I found solution and fix problem manually. I found that netplan make tunnel with 'ttl inherit' (on other routers ttl 255).

tunnel1: gre/ip remote 1.1.1.1 local 2.2.2.2 ttl inherit

After ip tunnel change tunnel1 ttl 255 command execution ospf starts to work.

How can I add to netplan ttl and pointopoint parameters to tunnel intarface? How to set commands like below to netplan file?

ifconfig tunnel1 pointopoint 10.2.2.1
ip tunnel change tunnel1 ttl 255
  • If you fixed your issue, don't put a solution inside of a question. Answer your question and accept your answer in two days. – Gryu Mar 31 at 21:32
  • i'm looking for issue, i can't add this to netplan. So after reboot i need to use some crutch. Run fixing command in rc.local or something like this. – Dr_Venom Apr 14 at 11:25
0

netplan currently lacks the ability to configure the ttl / hoplimit of a tunnel. This issue has been brought up in its issue tracker (bug #1846783), however its developers seem to have not paid attention to this.

Meanwhile you can configure the tunnel using connection managers that support setting this field such as systemd-networkd and NetworkManager, or try to run a script that calls ip tunnel after the tunnel has been brought up by netplan.

You might also be interested in the workaround described in the original feature request for supporting IP tunnels in bug #1799487, or elsewhere on this site

| improve this answer | |
New contributor
Charles Sloan is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.