So I switched to Kubuntu with this command: sudo apt install kubuntu-desktop and everything works fine except one thing: the login screen. The login screen is the default one and I don't know how to change it. I tried a few guides but they don't seem to work.

  • @DKBose That worked! Thanks!
    – Sam Pan
    Mar 31 '20 at 14:57
  • @DKBose can you please comment as an answer so that i can mark this as answered?
    – Sam Pan
    Mar 31 '20 at 14:59

By default, Ubuntu uses GDM3 (GNOME Display Manager) whereas Kubuntu uses SDDM (Simple Desktop Display Manager).

When you added kubuntu-desktop, you may have been offered the option to select either display manager and you may have chosen GDM3.

Now that you want SDDM, simply run

sudo dpkg-reconfigure sddm

See https://www.linuxuprising.com/2018/12/how-to-change-default-display-manager.html.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.