4

When I am not playing music or watching videos on my Ubuntu 18.04 install, there is a constant repeating audio loop thing that plays out of the right side of my headphones (the issue is not with my headphones, it happens with any headphones/earphones). The sound is similar to that which is made by a vinyl record player when the needle is first placed on the record. Now imagine that repeating every 2 seconds, out of only one ear.

Heres a link to what that vinyl thing sounds like: https://youtu.be/CclOy8IrDyQ?t=26

If I watch a video or play some music it stops. When I stop the music, it will start after about 10-15 seconds of silence.

Another way to stop it is to install PulseAudio Volume Control and to keep it open at all times. This is what I have been using to prevent myself from going insane. The noise will start again 10-15 seconds after PulseAudio is closed.

I've had this problem for a while, but I think it started when I was playing around with Audacity and audio recording with a microphone. I had probably installed some things which caused it to begin.

However, I have since done a clean reinstall of Ubuntu 18.04, and I still have the problem.

Help would be very welcome.

1 Answer 1

5

I experienced the same problem on Fedora 33 after switching from a headphone to a jack cable branched on a stereo amplifier. Honestly I don't know why it happened now or if this is related at all to the hardware output but here is how I solved it :

By killing pulseaudio and relaunching it in verbose mode ( pulseaudio -k && pulseaudio -v ), the following information stuck out :

[pulseaudio] module-suspend-on-idle.c: Sink alsa_output.pci-0000_0b_00.3.analog-stereo idle for too long, suspending ...

Now I remember having experienced something similar in the past, only it was a loud glitching noise popping when an audio source went idle or was restored. The solution is to keep the idle audio source from suspending. In /etc/pulse/default.pa, comment out the load-module module-suspend-on-idle instruction :

### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle

Judging from what I can read online and what I experienced, it's an old problem, sometimes funnily described as a "machine gun" sound. This question is month old now, and you probably solved it by yourself, but hopefully It will spare a headache to someone else in the future

Source : https://wiki.archlinux.org/index.php/PulseAudio#guvcview

3
  • Will this Fedora solution work with Ubuntu?
    – user1091774
    Commented Jan 3, 2021 at 7:18
  • In the meantime I had to create an install of Ubuntu 18.04. I met the exact same problem and luckily fixed it using this very method. Additional unrelated details : The "beeping" noise persists when I suspend the machine. If I power on the machine, the beep will start early in the boot and only stops when I log into the Gnome user session. Commented Jan 4, 2021 at 8:55
  • This solved it twice now for me. Thanks! Ubuntu 20.04, two different computers.
    – ck4e
    Commented Mar 5, 2021 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .