6

The top panel in Ubuntu studio vanished from my system. I have tried several suggested methods to restore it, but none have worked.

Today, I reinstalled the OS, but the panel is still gone. When I try to restore it with:

xfce4-panel -r

or open panel settings, I get an error message saying they failed and:

GDBus.error:org.freedesktop.DBus.Error.ServiceUnknown:
The name org.xfce.Panel was not provided by any .service files

I was getting that error both before and after reinstalling Ubuntu Studio.

Does anyone know how to solve this?

4 Answers 4

8

try running xfce4-panel once on the terminal. Works for me. I don't even know why that happened to me at one time. Probably needs to be launched again because it suddenly crashed, and it didn't have a way on restarting the program.

2
  • I did try that, to no avail. I ended up doing a clean install which solved the issue. I later upgraded to 20.04 LTS, and just last week did a clean install of 20.10. (BTW, due to Ubuntu Studio's switch from xfce to kde, there's no online upgrade option for 20.10)
    – Al Preston
    Commented Oct 30, 2020 at 18:52
  • Worked for me today, running xfce4-panel& from terminal. Commented Feb 24, 2021 at 15:18
6

Simple workaround which may help if xfce4-panel -r crashed

  1. on the first terminal run xfce4-panel which should launch panel
  2. on the second terminal run xfce4-panel -r which should restart panel
  3. close both terminals
1
  • great lifehack, thanks!
    – Dmitriusan
    Commented Oct 31, 2022 at 9:30
0

Don't run the command as the root user. Running it as a normal user will fix the issue.

0

For me, closing all applications in the current session and upgrading to xfce4-panel 4.18.4 solved the problem. However, I'm not entirely certain whether the upgrade was necessary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .