Second edit: Since this question keeps getting attention, I want to put a clear disclaimer at the top: if you are experiencing this problem, it will likely be solved by pressing and holding the left-most and right-most button on your pad at the same time for a few seconds. You will notice that it has worked when the light at the top gets brighter. Avoid messing with anything else until you have tried this solution. Reinstalling drivers can make the problem worse.

The original title of this question was "Only left half of Wacom Intuos S is working". The text of the original question preserved below. I have since figured out part of the problem, so I am updating this question.

I am using a Wacom Intuos S on Ubuntu 18.04. If I plug it into the laptop, the device automatically goes into Android mode. This is a known issue with Ubuntu. This is confirmed by the output of libwacom-list-local-devices (output shown in the original question) as well as the output of lsusb which lists the vendor ID of the device as 2d1f (as noted in the link above on the issue). The tablet then behaves erratically.

I can toggle the pad to PC mode by holding the leftmost and rightmost button for a few seconds. The tablet then seems to successfully switch to PC mode: lsusb recognizes the device, the vendor ID updates to the correct value, and the indicator light turns on more brightly. However, now the device does not work at all: the cursor does not respond to the movement of the stylus, it is not recognised by Settings (gnome-control-center), and libwacom-list-local-devices does not list it at all. xsetwacom --list devices also comes up empty.

On my home laptop (very similar to my work laptop) switching the pad to PC mode fixes the issue: I can use the tablet without changing anything or updating any drivers. This is also true for a colleague, who was struggling with exactly the same issue (also on Ubuntu). This suggests to me that my attempt to get my drivers into their most recent versions on my work PC is actually what broke the tablet.

What do I need to do so that my tablet is recognized by my Ubuntu PC when it is in PC mode?

Original question text:

My new Wacom Intuos S connects to my Ubuntu laptop, and responds to input, but only its left half (or really, left third) works properly. In the image below I have marked the area that works properly.

Wacom Intuos S with red rectangle on left part of pad

If I move my stylus outside the rectangular area, my cursor still responds to vertical movement (i.e. moving my stylus still causes my cursor to go up and down) but no longer to horizontal movement (i.e. moving my stylus does not cause my cursor to move left to right).

Listing my devices with xsetwacom lists only my stylus and eraser -- this is inconsistent with an example I found elsewhere, which lists also a cursor and a pad -- but I am not sure if that relates to the problem.

mees@mees-ThinkPad-L480:~$ xsetwacom --list devices
Wacom Co.,Ltd. Intuos S stylus      id: 9   type: STYLUS    
Wacom Co.,Ltd. Intuos S eraser      id: 16  type: ERASER    

Running libwacom-list-local-devices seems to give a relevant hint to the problem:

Name=Wacom Intuos S (Android Mode)

[full output omitted, can report if necessary]

The reported height and width seem to match the aspect ratio of the part of the device I am actually able to use. I can find the config file (?) that lists the information above, and simply edit the width field to have a different value (e.g. 5), but that does not actually change anything except the output of libwacom-list-local-devices (I have changed it back to the default value of 2 for now).

This problem seems to be Ubuntu-specific: I have tried the tablet on my boyfriend's Windows laptop, and it works correctly (after installing the relevant drivers). I have also tried it on my personal laptop, which is nearly identical to my work laptop (also a Lenovo Thinkpad with Ubuntu 18.04) and I have the same problems.

What can I do to get my Intuos pad to work properly? Or how can I effectively troubleshoot?

Please let me know if I should provide any further/more detailed information.

  • Been experiencing this same problem for over a year. On my laptop if I booted with the tablet plugged in it would start in regular (not android) mode but my new computer doesn't. Hopefully this gets fixed soon! :)
    – N8tron
    Jan 7, 2021 at 11:40
  • 1
    @N8tron, see the comment I just added at the top of the question. Jan 7, 2021 at 14:35
  • yes that is definately the best advice and is what i did. Still though, i feel like this problem should go away upstream. The OS should not be putting our tablets in android mode :)
    – N8tron
    Jan 7, 2021 at 15:26
  • I recommend putting the disclaimer on top in bold. That is definitely what will happen to most, and this issue still persists.
    – Cain
    Jul 18, 2022 at 8:19

4 Answers 4


I had the exact same problem. I think it worked for a bit of time, then launched into android mode (I don't know why). If I had know how to reset it then (hold buttons 1 and 4), I bet everything would've been fine, but instead I tried to reinstall and debug. My eventual solution is below, followed by some notes. Hopefully some of this will be helpful to someone...

What worked for me: at some point during the process of trying to get my tablet to work, I tried to re-install wacom-input (version 0.45.0). Eventually, simply running sudo make uninstall from the wacom-input installation directory fixed all of my problems, reverting to the system default driver I think.

My system information: ubuntu 18.04.4 LTS, GNOME 3.28.4.

Tablet information: Intuos PEN (model number CLT-6100WL) (bluetooth capable).

Some notes about how I think I broke things:

  • At some point, I also tried to purge libwacom-bin, libwacom-common and/or libwacom2, and ended up rendering my desktop environment unable to launch. Even when I reinstalled ubuntu-desktop (entering the shell directly with F3 during the endless boot screen I was getting) my keyboard didn't work and I had to also sudo apt install xserver-xorg-input-all using the onscreen accessibility keyboard. How this is possible is truly astounding to me... and makes me sad about the state of (even extremely mainstream) linux.

  • I ran into the ``duplicate keys'' problem described here, and I think I deleted some of the files in /usr/share/libwacom to remove duplicates. I'm not sure if it was caused by me, or some sequence of installations/uninstallations, but at some point the file I thought was corresponding to my device (intuos-m-p3-wl.tablet) was missing. Creating that file, and populating it with sensible data, didn't help (even after restart). (I am not sure the exact relationship between files in this directory and the behavior of the drivers/libraries. Would love an explanation from someone knowledgeable.)

Some notes about how things are working now:

  • Now that things are working though, it seems my device actually corresponds to /usr/share/libwacom/intuos-m-p3.tablet. Reason: libwacom-list-local-devices (and lsusb) give the address 056a:0378, which appears in the file intuos-m-p3.tablet. I am now able to toggle android mode at will (not that I want to) and the address changes to 2d1f:0378, which appears in intuos-m-p3-wl-android.tablet. So maybe linking the device to "non-WL" version of the configuration sidesteps the issue where linux is misidentified as android??

  • My tablet even works in bluetooth. However, it seems to no longer be recognized by libwacom, as it doesn't appear in settings or with libwacom-list-local-devices.

  • Bizarrely, when I connect the tablet, it appears twice, with identical entries, under libwacom-list-local-devices.

  • Other people are having this issue. Presumably you've found these resources: help, issue filed. Unfortunately these pages didn't solve my problem directly.

  • 1
    This comes closest to the experience that I had out of anyone I've found with this issue so far, including the idea that reinstalling/debugging things caused the 1+4-button fix to fail, the duplicate keys problem (I'd almost forgotten about that) and of course the desktop environment issue (although my problem wasn't as bad as yours). So I'll award you the bounty and hope that someone else has use for this detailed explanation. Apr 8, 2020 at 7:15
  • Interestingly our devices are not identical, and everyone else I've heard so far was struggling with a Wacom Intuos S, but maybe those are just popular now because they are relatively cheap. Apr 8, 2020 at 7:16

So I Got this problem today. On ubuntu 19.10 with Intuos BT S. Also system utils displayed the tablet and stylus as disconnected.

I used this command libwacom-list-local-devices which showed this on device name Wacom Intuos BT S (Android Mode). Also xsetwacom --list dev did list only STYLUS and ERASER.

I first followed all the instructions on The linux Wacom Project. After successful installation I restarted my PC. And for the sake of not messing anything else also disabled all workspaces and display related tweeks. Then I verified that everything is running as it should according to The linux Wacom Project instructions.

Now my wacom table was detected by system utils but still not working properly (still in android mode).

After that I had the same issue still. So I held the left-most and right-most button of Intuos simultaneously for 10sec. After that everything worked like a charm.

When I run xsetwacom --list dev now also the PAD and CURSOR are properly showing.

Also I recomend looking into Dual and Multi Monitor Set Up instructions. So that you can verify that your settup is recognized correctly.


I encountered the same problem today - no idea what the cause is. Anyway, I fixed it by removing the package libwacom-bin and then restarting my laptop. Please watch out as removing libwacom-common or libwacom2 will remove a bunch of other important packages alongside it. (Not silently, it will list all packages it will remove, but still.) So only remove libwacom-bin. I'm on KDE Neon btw. Hope it will work for you too.

  • Unfortunately this did not work for me, nor did reinstalling it afterwards, nor did apt install --reinstalling the other two packages. Mar 31, 2020 at 8:07
  • Sorry to hear, I hope you can find a solution soon
    – banpot
    Mar 31, 2020 at 13:15

I have by now (more or less) solved my problem. If you have encountered the same problem, the first thing you should try is to hold the left-most and right-most button of your Intuos simultaneously for several seconds. This has solved the problem for several of my colleagues, and one person on this forum (who has since deleted their answer).

It did not work for me. I tried many different things, but in the end, I think this is what did it:

  • Uninstall libwacom-bin, libwacom-common and libwacom2 with the --purge option on apt. Carefully look for error messages and warnings during this process: I was warned that the directory /usr/share/libwacom/layouts could not be deleted, and I deleted it by hand.
  • This (or possibly something else) was sufficiently aggressive that, upon rebooting my computer, I found that I had uninstalled by desktop environment. I had to run sudo apt install ubuntu-desktop to get it back (it doesn't seem to have done any lasting damage).
  • I then reinstalled libwacom-bin, libwacom-common and libwacom2, and rebooted again. Now my tablet "worked" -- which is to say, it still does not show up on wacom-list-local-devices or in the Settings, but it is usable using the xsetwacom command line interface.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .