1

I have just started using Okular now that I've installed Kubuntu (18.04).

Previously, when printing a PDF, I would get an option about scaling. For instance, Adobe Reader has options such as "Fit to page" and "Do not scale." I don't see options like that in the print dialog from Okular.

The PDF I have is exactly sized already, and should not be scaled during printing. The size of the PDF pages is 8 1/2" by 11", which is exactly the size of my paper.

However, when I print from Okular, the printout has extra (and uneven) margins, showing that the PDF was scaled down during printing.

How can I avoid this when printing from Okular so that the PDF prints at exactly the page size? Or is it absolutely necessary that I use another program to do my printing?

(I'd rather use Okular as it is the default viewer with Kubuntu and if possible I'd like to be able to recommend this distro for non-technical family and friends, and be familiar with the default applications they'll then be using.)


What I've tried already: clicking "properties" for the printer from the print dialog, and then in the "page" tab reducing the size of all four margins from the default "0.20in" down to 0. This did not have any effect on the next printout.

2
  • What is the size of the paper loaded in the printer, according to the printer driver?
    – xenoid
    Mar 28 '20 at 23:25
  • @xenoid it says page size letter, so that seems correct. Also I don't think installing Kubuntu (instead of Ubuntu with GNOME) would have changed the printer drivers, would it?
    – Wildcard
    Mar 28 '20 at 23:56
2

Created an image in LibreOffice Draw with precise dimensions.

  • Printed directly from Draw, image dimensions are OK.
  • Export to PDF
  • Print from Okular with defaults, image is scaled down
  • In Draw, File>Open and open the PDF then print, dimensions are OK
  • Looking at the Okular print dialog more closely, I stumble upon this set of options ("Options" fold out):

enter image description here

This works, but... the image seems to be printed shifted so that it fits the printable area. So if the initial PDF contents just fit the printable area the right edge is going to be trimmed.

5
  • Thanks. I don't have that option; under "Print annotations" and "Force rasterization" the rest of that tab is empty. This is with a Canon MF4700 Series, by the way, though I don't think that part should matter.
    – Wildcard
    Mar 29 '20 at 20:31
  • 1
    @Wildcard this is running 19.10, and in a near future you should be installing 20.04 not 18.04.
    – xenoid
    Mar 29 '20 at 20:57
  • Thanks, I guess I'll just wait and see if it improves with the new version next(ish) month. And probably use Adobe Reader if I have to print in the meantime....
    – Wildcard
    Mar 29 '20 at 21:02
  • @xenoid : Doesn't matter. I've just replicated the reported problem with Ubuntu 20.04 on an HP LaserJet cp1025nw. Feb 5 at 23:50
  • can I set "None; print original size" as default Aug 16 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.