A number of games, Emacs, and the terminal make extensive use of the Alt key. Can Unity be configured to respect this key, rather than launching the HUD with it?

  • 40
    the HUD is really annoying – Oki Erie Rinaldi May 4 '15 at 7:34
  • 8
    I agree. Having the Alt key launch the HUD pretty much guarantees that you're going to interfere the the proper functioning of most non-trivial apps. – Gino Jun 23 '15 at 3:06
  • It makes it extremely difficult to follow the Unity3d game engine tutorials. Alt is constantly used when creating the game world, for example rotating the scene viewport, which happens dozens of times a minute if you are creating a complicated object. – don bright Jan 14 '17 at 2:24
up vote 487 down vote accepted

Open the System Settings application either by going to Session Indicator in Unity panel, or by searching for System Settings using the HUD.

enter image description here

Then go to Keyboard > Shortcuts > Launchers. You can redefine the HUD key with the Key to show the HUD option. Pressing Backspace will disable the HUD shortcut altogether.

Screenshot of Keyboard settings window, in the Launchers section

If you set it to Alt manually, the setting distinguishes between the left and right Alt key. So if you want to maintain general behaviour and still use Alt combinations, this may be an alternate solution for you.

  • 8
    This doesn't work for me. The left alt key still triggers HUD. I wonder if some update occurred which nullified this fix. I'm really surprised that this is even an issue: Emacs anyone? Geez. – Dogweather Sep 29 '12 at 4:13
  • 17
    I set it to Alt+Windows as it kept popping up when I was switching tabs in Firefox. This combo works very well and doesn't interfere with normal Dash operations. – japzone Dec 4 '12 at 15:34
  • 3
    Yes! Finally got rid of it! After all this time I still don't know the purpose of this HUD "Execute command"... Can anyone explain? – Lucas Pottersky May 9 '13 at 14:43
  • 8
    Wow. I am kicking myself for not searching for this sooner! (Also, in retrospect, it's so obvious... I really shouldn't have had to search for it at all.) – Dan Tao May 20 '13 at 19:09
  • 5
    It should have been just alt-super by default, especially with all the games coming up for Linux. Thanks. – kelvinilla Jul 15 '13 at 9:19

You can use compizconfig-settings-manager Install compizconfig-settings-manager to change the key used to show the HUD.

To install it, run the following command in a terminal:

sudo apt-get install compizconfig-settings-manager

After installing it, open it (ccsm) and go to Ubuntu Unity Plugin.

enter image description here

Click on the button for the option Key to show the HUD and a dialog similar to the one shown below will appear.

enter image description here

Click on Grab key combination and press your desired new key combination and press enter. After that, click on OK button and the new key combination will trigger the HUD from now on.

  • 2
    This won't work on Unity-2D... – nastys May 2 '12 at 19:14
  • 2
    @nastys it at least work in Unity 3D very good – Anwar Oct 10 '12 at 8:05
  • 2
    Keybindings from CCSM may still be respected when running Unity2D. – Takkat Oct 10 '12 at 8:17
  • Really. When unity is activated some of key settings in standard shortcuts are ignore. Thanks – ruX Apr 2 '13 at 9:24
  • 1
    Thank you. This solves the problem in Evolution caused when inserting the mail recipients and a comma and space are inserted after pressing AltGr key to obtain the @. Thank you very much! – Geppettvs D'Constanzo Jun 5 '13 at 18:04

On "Ubuntu 13.04 (raring)" you can execute:

disable HUD:
dconf write /org/compiz/integrated/show-hud '[""]'
enable/reset HUD ('Alt L'):
dconf write /org/compiz/integrated/show-hud '["<Alt>"]'
  • works even if the setting in not listet in the system settings testet with 14.04 (development branch) – key_ Feb 11 '14 at 11:07
  • it works at 14.04 – Moreno Jul 7 '14 at 19:33
  • 1
    Do dconf changes require a reboot? I'm trying to modifying the screenshot command and it doesn't seem to take effect right away. – gonzobrains Jan 8 '15 at 20:07
  • I think the &lt; and &gt; should be < and > when actually typing it in the command line; at least for me, when I used the encodings it didn't work, but when I used ["<Alt>"] it did work. – sigmazero13 Jun 20 '16 at 20:01
  • Hint: It should be running by your user, not by root via sudo – vp_arth Jan 17 '17 at 4:38

You can configure HUD with help of gsettings:

DESCRIPTION
       gsettings offers a simple commandline interface to GSettings.It lets you get, set or monitor an individual key for changes.
  • To get current key run following command in terminal:

    $ gsettings get org.compiz.integrated show-hud
    ['<Alt>']
    
  • To change key (let Alt+Super) run following command in terminal:

    gsettings set org.compiz.integrated show-hud "['<Alt><Super>']"
    

Now when you press only Alt then HUD not shown. But it is configured to shown by Alt+Super!

You can set valid Key-Combination instead of "['<Alt><Super>']".

  • I restored using gsettings set org.compiz.integrated show-hud "['<Alt><Super>']" thanks! – insign Nov 19 '14 at 20:35
  • What's the difference between using this and dconf write/read? – gonzobrains Jan 8 '15 at 20:08
  • 1
    @gonzobrains Visit wiki.gnome.org/action/show/Projects/dconf which states dconf is a low-level configuration system. Its main purpose is to provide a backend to GSettings on platforms that don't already have configuration storage systems. – Pandya Jan 9 '15 at 12:45
  • 2
    @gonzobrains At API Also Note: Most applications will not want to interface directly with dconf, but rather with GSettings. – Pandya Jan 9 '15 at 12:47
  • 1
    @gonzobrains 12.04 uses gconf, not dconf/gsettings – wisbucky Mar 14 '17 at 23:10

Well it's Called HUD. The new feature of Unity.

To prevent it from appearing, you can disable its key binding in keyboard shortcuts.

Open system settings by going to Session Indicator in Unity panel.

enter image description here

In system settings select Keyboard. Under Shortcuts tab, Click on `Key to show the HUD. and press Backspace to disable it. That's it!

enter image description here

  • 9
    Clearing the key doesn't disable the HUD option – Anwar Oct 3 '12 at 4:46

In Ubuntu 12.04 I changed shortcut for summoning HUD in System Settings... > Keyboard > Shortcuts > Launchers > Key to show the HUD.

Now my left Alt is happy again :-)

In the system settings, just change the keyboard shortcut for "Key to show the HUD" (under 'Launchers'). As a suggestion, set it to activate when both the alt keys are pressed at the same time, instead of just one. It makes using VMs much less annoying.

Ubuntu 14.04.1: Opening an Emacs Session in which Typing Alt doesn't Open the HUD.

  1. In the Desktop environment, type Ctrl+Alt+F1 to enter a terminal screen.
  2. Enter your username and password as prompted.
  3. At the command prompt, open an Emacs session by typing emacs.
  4. Now, using Alt as Meta won't open the HUD.
  5. Return to the Desktop at any time by typing Alt+F7.

Source: An Introduction to the Command Line_ (p.12) on the FLOSS Manuals page.

  • 1
    Telling the user to bail out to one of the ttys isn't a helpful option for most users and, on some computers, isn't usable. I have a laptop with a 4K display that produce text that is pretty much illegible at a reasonable distance. – Jeremiah Peschka Aug 2 '16 at 2:21

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.