My system:

Laptop Dell inspiron 15 3000
RAM: 16 GB
SSD 480 GB Kingston
Intel Core i3 7th Generation
OS: Ubuntu 18.04.4 with Software and System Updates
Web Browser: Mozilla Firefox, Google Chrome, Palemoon. All latest.
Terminal emulator: Yakuake, gnome-terminal.
Other Terminal: TTY1
Internet service provider connection speed: 100 Mbps (asymmetric)
Full upgrade: march 23, 2020

The problem

Just recently noticed that my mkv videos stopped working just after a system upgrade. That's why I requested help here: Error on videos (.mkv) after software upgrade. And the problem was partially solved.

Nevertheless I didn't notice that some other video overlay functions stopped working, like the overlay video which is used by AnyDesk to create the remote control session. Please see this screenshot.

enter image description here


Just entered the Ubuntu default desktop environment, and I noticed some weird green color artifacts on the desktop, which won't render on the top of the windows, just on the desktop.

enter image description here

Can somebody please help me to revert or fix the problem the upgrade created?

If you need further information please let me know. I don't know where to start the investigation and what I would do is to reinstall everything. But I would prefer not to.

Thanks in advance.

  • 1
    Does this answer your question? Fuzzy graphics after upgrading to Ubuntu 20.04 – karel Jun 5 '20 at 4:38
  • 1
    Yes. Basically, what Eliah Kagan said is the same I did to solve my issue. Thank you very much @karel – Geppettvs D'Constanzo Jun 5 '20 at 15:17
  • 2
    BTW: That is a partial solution, as it solves the fuzzy graphics but removed the GUI acceleration, so I experience some issues when doing some things with 3D, video editing, games and other things. – Geppettvs D'Constanzo Jun 5 '20 at 15:18

Well, basically I found a solution while searching. It seems something was wrong with the latest Intel driver update, so I searched for "How to revert Intel Driver" and I got to this answer: Intel screen tearing - Ubuntu 18.04, of which this command line solved everything:

sudo apt purge xserver-xorg-video-intel

Just needed to reboot after that, and everything is back to normal.

Even the remote control overlay using AnyDesk is solved now.

Somehow, it also affected the way in which xrandr recognizes my monitors, anyway, if it works I don't care how the system calls the monitors.


enter image description here


enter image description here


enter image description here

Good to find a solution, I was already backing up everything in order to reinstall.

  • Thanks a lot. I used the solution to solve a similar issue. – Tanvir Apr 30 '20 at 11:50

I was having the same problem but this approach solved it for me.

Go to Nvidia X Server Settings > PRIME PROFILES > Select NVIDIA ON DEMAND

Nvidia X Server Settings

Then restart your system and you are good to go.

I hope you will find this useful.

  • 1
    That should work for NVidia's, but my case is for Intel. This should help people having systems with an NVidia. Thank you – Geppettvs D'Constanzo Sep 5 '20 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.