0

I installed the Zorin OS theme on my gnome-shell. When I maximie any window the top bar transitions into a off putting white-black gradient color which I do not desire. A semi transperent top bar which matches with the theme appears only when the the applications are minimized. I have included screenshots.

Top bar when windows are minimized

Top bar when windows are maximized

How do I make the top bar same as it is while minimized on maximized windows as well?

0

After several trail and errors found this code is required to add at the bottom of your Zorions gnome-shell theme file gnome-shell.css..

/* panel color */
#panel.solid {
  background-gradient-direction: vertical;
  background-gradient-start: rgba(255, 255, 255, 0.5);
  background-gradient-end: rgba(255, 255, 255, 0.5);
  text-shadow: none;
}

the rgba color I have got from the text entry /* TOP BAR */ with in the gnome-shell file. You can change what ever color you want..

/* TOP BAR */
#panel {
  background-color: rgba(255, 255, 255, 0.5);
  /* transition from solid to transparent */
  transition-duration: 500ms;
  font-weight: bold;
  height: 2em;
  font-feature-settings: "tnum";
  box-shadow: none; }

enter image description here

enter image description here


My Customizations for windows normal and maximized..

enter image description here

| improve this answer | |
  • 1
    I really thank you for your effort. It worked like a charm – Shobit Puri Mar 28 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.