I'm running Ubuntu 18.04 (Kubuntu, actually) on a Lenovo ThinkPad L540.

I installed the latest Blender from the PPA repository like so:

sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt install blender

(The version string is 94552-4c0cca78eb4-0thomas~bionic0 and the description includes This is version 2.8 obtained by pulling the last version in the master branch of the blender git repository. According to the Blender website, that should be 2.82a.)

Attempting to run this new blender gives the error:

/usr/lib/blender/blender: error while loading shared libraries: libLLVM-6.0.so.1: cannot open shared object file: No such file or directory

I then discovered that my scrollback history wasn't set up right, so I don't have the list of packages installed when I ran the earlier commands.

I'd earlier (a year ago) installed Blender 2.80 manually (not from a .deb but from a tarball); that installation still opens without complaining about libraries.

I've searched the error and libLLVM online and found a suggestion to use sudo /sbin/ldconfig -v, which (after checking the man page) I tried, but it had no effect; the error on trying to run the new blender is exactly the same, including in a new Konsole window.

  1. How can I get the dependencies installed correctly so the program will open, and
  2. Is there somewhere I should report this as a bug?
  • 1
    Perhaps bypass this slightly broken package and simply run: sudo snap install blender --classic ? On my 18.04 system this successfully installed Blender version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: 375c7dc4caf4, type: Release.
    – andrew.46
    Commented Mar 28, 2020 at 5:55
  • @andrew.46 I do prefer .deb installations, but thanks for the suggestion. I don't like the overhead of snap packages and have thus far avoided them successfully.
    – Wildcard
    Commented Mar 28, 2020 at 6:10

3 Answers 3

  1. Do this to fix dependency error:

    sudo apt install llvm-6.0
  2. You can report any bug to the maintainer here: https://bugs.launchpad.net/~thomas-schiex

  • Thanks for the link; I let him know. That's his answer below and the dependency is fixed now. :)
    – Wildcard
    Commented Mar 28, 2020 at 10:14
  • Hello,This problem is still in ubuntu 20.10+blender 2.91,any workaround?
    – Alex Luya
    Commented Jan 2, 2021 at 2:47
  • @AlexLuya, Can you elaborate, after installing this dependency, the problem persists?
    – Olimjon
    Commented Jan 3, 2021 at 2:54

Thanks for reporting this, llvm-6.0 is now in the dependencies. An new build will be available soon.

  • 1
    Hello,this problem is still in ubuntu 20.10+blender 2.91,any workaround?Since it is hard to install llvm-6.0 in ubuntu 20.10
    – Alex Luya
    Commented Jan 2, 2021 at 3:02

Attempted installation of Blender v2.92 using schiex's PPA onto Xubuntu Studio 20.04 appeared successful but does not run. Attempt from terminal reports a missing dependency. Installing llvm-6.0 has fixed this; it now runs (at least to the splash screen ---I have not done more than that at this time).

  • This should be comment not question.
    – Salem F
    Commented Mar 23, 2021 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .