1

Long story short, I accidentally deleted a part of my ubuntu-desktop trying to remove KDE. I tried to reinstall the missing packages through the virtual terminal but it didn't work as there was no internet connection (WiFI was working fine on the desktop). I tried nmcli dev but neither the Ethernet nor wireless device was shown.

I checked for the network controller using sudo lspci and lshw -C network and it popped up both times. It's a Intel Wireless 3160.

I then thought it was because I was missing the firmware so I went onto Windows (I have a Windows 10 dual-boot) and downloaded the firmware from the Intel website onto my USB.

I then went back into the Linux virtual terminal and copied the firmware to /lib/firmware. The Intel guide said to check the kernel configuration to check if Config_FW_Loader is on but I'm not sure how to do that. I checked the firmware directory and the firmware I downloaded is on there but it's the only one in green text.

I then tried to load the driver. I did lsmod and I couldn't see the wireless driver so I then did sudo modprobe iwlwifi to see:

modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='iwlwifi'
modprobe: ERROR: could not insert 'iwlwifi': Unknown symbol in module, or unknown parameter (see dmesg)

I tried sudo modprobe iwlmvm and I got something different:

modeprobe: FATAL: Module iwlmvm not found in directory /lib/module/5.3.0-28-generic.

I don't know what to do from here. Can anyone help me?

4
  • iwlwifi should already be in the kernel therefore it would not appear separately. – K7AAY Mar 27 '20 at 20:07
  • 1
    @K7AAY ok okay, but why doesn't the terminal show a device when I do nmcli dev? I thought it was because the drivers weren't working, it must be something else then? – Allajo Mar 27 '20 at 20:16
  • 1
    @K7AAY Btw, when I do lshw -class network both the wireless and ethernet controllers are labeled "unclaimed". Which makes me think this is a problem with the drivers. – Allajo Mar 27 '20 at 21:12
  • Seems likely, but I continue to not have a solution for you. – K7AAY Mar 27 '20 at 21:17
0

Got it to work. Booted up an older version of the kernel from grub. Wireless still didn't work but ethernet did. I was then able to redownload ubuntu-desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.