2

I am unable to open the Settings on my installation of Ubuntu 18.04. There are multiple questions on the site already related to this, but the details of their situations seem different.

If I open Settings by searching the Settings application and clicking on it, its name appears on the top of my screen next to a spinning wheel for a few seconds before disappearing (similar to the situation in this question). If I run gnome-control-center directly from the terminal, it hangs for a few seconds before exiting with a timeout message.

mees@mees-ThinkPad-L480:~$ gnome-control-center
Failed to register: Timeout was reached

I can however get the version:

mees@mees-ThinkPad-L480:~$ gnome-control-center --version
gnome-control-center 3.28.2

I have run

sudo apt remove --purge gnome-control-center
sudo apt autoremove
sudo apt install gnome-control-center

(from this answer) successfully, but it does not solve the problem. The suggestion sudo apt-get -f install --reinstall gnome-control-center (this answer) did not help either.

Some of the answers mention nvidia drivers, but I do not have an nvidia graphics card, so this should (?) not be the issue.

I was in the process of trying to update my Wacom drivers (following these instructions) when the problem occurred.

  • killall gnome-control-center and show gnome-control-center --verbose maybe someone can see what goes wrong. – nobody Mar 27 '20 at 15:41
  • 1
    With --verbose nothing changed, but actually your other solution more or less worked, let me answer my own question (may not fit into a comment). – Mees de Vries Mar 27 '20 at 15:43
2

The problem in my case was that I had messed up the installation of the Wacom drivers. Because the gnome-control-center uses the Wacom drivers, and I had my Wacom tablet plugged in, it would hang.

I had already figured that this might be the problem, so I disconnected the tablet, but the problem seemed to persist. What I did not understand was that the problem was now different: the hanging version of gnome-control-center was still running in the background. So for me to fix my problem I had to:

  • Disconnect the tablet.
  • Run killall-gnome-control-center.
  • Fix the problems with the drivers before plugging in the tablet again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.