1

I'm trying to work out why I can get the Ctrl+Alt+P shortcut working properly in Sublime Text. I've worked out that it's being swallowed before it's getting to Sublime but I'm not sure how to proceed from here.

I came across this post Ctrl + Alt + P restore from maximization shortcut, how to disable it? which talks about a Unity Tweaks tool, which doesn't install properly and sounds like Gnome Tweaks - I'm not sure if they're the same tool but the options discussed don't exist as may not be relevant 7 years later.

Does anyone have any suggestions on how I can diagnose why my keybinding is being swallowed so I can re-map whatever is using it?

I'm using version 18.04.4 LTS for reference

1
  • 2
    Please edit your question to indicate which version of Ubuntu you are using. Since 18.04 LTS the default desktop environment is Gnome not Unity.
    – graham
    Commented Mar 27, 2020 at 15:32

2 Answers 2

2

Mentioned issue in ClipIt issue has been fixed recently.
ClipIt 1.4.5 is not in Debian or Ubuntu repos yet, but patched packages are available in ppa:
https://launchpad.net/~afelinczak/+archive/ubuntu/ppa

2
  • Thanks, I don't really know what PPA is - could you share how you might install from there?
    – Ian
    Commented Jun 11, 2020 at 19:33
  • Actually you can download deb package from ClipIt github page. PPA is unofficial repository maintained by third party developers. You can add this one using sudo add-apt-repository ppa:afelinczak. After that if you try to install ClipIt, you will get package from PPA instead of Ubuntu Repositories. Commented Jun 12, 2020 at 20:59
1

So it turns out that an application called ClipIt that I was using had tried to bind the keys but was now failing (never used to do this). So I hadn't realised it was using them/when attempting to press them they did nothing due to the failed binding.

I discovered this GitHub issue for anyone with the same problem https://github.com/CristianHenzel/ClipIt/issues/97

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .