0

I want to install a script on my locahost, i installed apache2, php7.2 and mysql

The problem that i have is running this command:

phpenmod mcrypt

it ALWAYS trow the same thing when i trow it in the console:

WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.2/mods-available WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.2/mods-available

PD: SOLUTION founded(see comentary)

New contributor
Munsko is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

SOLUTION:

After re-installing the entire SO, in a clean instalation i made this:

https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-ubuntu-18-04

Then:

https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-on-ubuntu-16-04

Then:

https://websiteforstudents.com/install-php-7-2-mcrypt-module-on-ubuntu-18-04-lts/

And lastly:

Enable extension for apache

echo "extension=mcrypt.so" | sudo tee -a /etc/php/7.2/apache2/conf.d/mcrypt.ini

and:

echo "extension=mcrypt.so" | sudo tee -a /etc/php/7.2/mods-available/mcrypt.ini

sudo phpenmod mcrypt

The three last steps are from:

php-mcrypt package missing in Ubuntu Server 18.04 LTS

I really thanks to Epskampie and Werner for the solution

New contributor
Munsko is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Munsko is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.